Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#29262 closed update (duplicate)

sox: update to 14.3.2 which fixes crashing bug

Reported by: wiking@… Owned by: davidfavor (David Favor)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: sox

Description

Current sox version (14.3.1 rev 2) keeps crashing under latest SL in x86_64 mode. I've upgraded it to 14.3.2 locally as according to the release notes: "Fix segfaults on Mac OS X playback. Recording now works on OSX."

And now both playback and recording works without problems/segfaults.

I've attached the diff file for the Portfile of sox.

Attachments (1)

Portfile-sox_14.3.2.patch (927 bytes) - added by wiking@… 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by wiking@…

Attachment: Portfile-sox_14.3.2.patch added

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Cc: david@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to david@…
Summary: SOX keeps crashingsox: update to 14.3.2 which fixes crashing bug
Type: defectupdate
Version: 1.9.2

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Resolved in #29271.

comment:3 in reply to:  2 Changed 9 years ago by wiking@…

opening another ticket about the same thing 12 hours after the first ticket and marking the first ticket as a duplicate of the new one... it's just ain't cool IMO.... but thanx for applying the patch.

Replying to ryandesign@…:

Resolved in #29271.

Note: See TracTickets for help on using tickets.