Opened 10 years ago

Closed 4 years ago

#29324 closed defect (invalid)

sane-backends update issue

Reported by: zelegolas@… Owned by: aguynamedryan+sane@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: sane-backends

Description

Hi

When I upgrade sane-backends Mac Port generate this message:

Error: Target org.macports.activate returned: Image error: /opt/local/share/locale/da/LC_MESSAGES/sane-backends.mo already exists and does not belong to a registered port.  Unable to activate port sane-backends. Use 'port -f activate sane-backends' to force the activation.
Log for sane-backends is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_sane-backends/main.log

Attachments (3)

main.log (75.3 KB) - added by zelegolas@… 10 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_sane-backends/main.log
scanadf.log (52.8 KB) - added by zelegolas@… 10 years ago.
scanadf (with export SANE_DEBUG_AVISION=127)
scanimage.log (47.0 KB) - added by zelegolas@… 10 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by zelegolas@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_sane-backends/main.log

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to aguynamedryan+sane@…
Port: sane-backends added

Please remember to fill in the Port field and cc the maintainer.

comment:2 Changed 10 years ago by aguynamedryan+macports@…

I'm sorry to hear the upgrade isn't going smoothly for you. I did not encounter any activation errors on my end.

In the past, when I encountered such problems with other ports, I simply run:

sudo port -f activate some-port

and that seems to resolve the issue for me without causing any issues in the long run.

I looked through a few pages of the wiki and found that most people recommend a similar course of action. These are the relevant links I found:

  • FAQ - a page that suggests you do as I describe above
  • ProblemHotlist - a page that suggests the more drastic approach of zapping your entire MacPorts installation (you probably want to avoid this)

I also looked at tickets for other ports that have run into this problem:

  • This one suggests that if you have a case-sensitive filesystem, you might have a problem: (#28634)
    • The solution was to force the activation
    • This one also suggests that maybe you need to migrate from the flat DB to sqlite for you MacPorts database
  • This one suggests removing the file, then attempting activation again (#26757)
  • And this one suggests that these kinds of bugs are non-issues unless it can be demonstrated that MacPorts itself is failing to record files in its filemap (#26114)

I stopped looking through tickets after that because the first handful I saw all seem to suggest that this is not a bug that a maintainer can really addres.

I hope you find this information helpful. If you find there is anything else I can do, please let me know.

comment:3 Changed 10 years ago by zelegolas@…

Thanks to follow this ticket I all files related to sane on folder /opt/local and sub-folders. After that I was able to install sane-backends but I tried scan something with my device it was not able to feeds the page. I checked the device (Xerox DocuMate262i) and it's look fine. Is that possible to downgrade to the previous released? (I didn't have any issue with the previous version)

comment:4 in reply to:  3 Changed 10 years ago by aguynamedryan+macports@…

Replying to zelegolas@…:

Bummer! Here's a wiki page on Downgrading to an older port.

However, I would encourage you to try a bit of debugging with the current version of sane-backends before you give up and downgrade. Perhaps the most recent version of sane-backends has introduced a regression? In that case, you're probably not the only one running into this problem. If you can help locate and squash the bug, the upstream maintainers of SANE can fix the bug for everyone.

I'm surprised to hear that your DocuMate262i stopped working as it looks like support for it was only added to the avision backend between versions 1.0.21 and 1.0.22

Unfortunately, my experience with SANE is limited exclusively to the Fujitsu brand of scanners. I don't have access to a DocuMate262i so I can't do any testing on my side.

Here is a link to the page of the avision backend maintainer's site. He might be able to better help you track down the problem: Maintainer's Site

If that doesn't work, here are some links that discuss DocuMate262i scanners and SANE:

If those all turn into dead-ends, let me know and I'll try to help you debug.

comment:5 Changed 10 years ago by zelegolas@…

I'm surprised to hear that your DocuMate262i stopped working as it looks like support for it was only added to the avision backend between versions 1.0.21 and 1.0.22

I know. I applied by myself the patch you mention at "Page (in french) about using the DocuMate262i with SANE" and it was working perfectly :)

Now when I run this command:

scanadf --source "ADF Duplex" --mode Gray --output-file "DocuMate262i/Page-%04d.ppm" --start-count 1

After a few second it's return:

scanadf: sane_read: Error during device I/O
Error during device I/O
Scanned 0 pages

And if I try again I have this message:

scanadf: sane_start: Document feeder jammed
Document feeder jammed
Scanned 0 pages

And it's normal because my paper it's blocked on the device.

Because the modification on the backends layer it's very small and because it's exactly the one that i applied by myself i'm not sure if the issue come from sane-backends. It's may be an issue with sane-frontends or the usb layer. But I don't know how I can check that. I will read your links (again) and see if I can do something with it... I you thinks about some informations, tricks or anything could be help just let me know.

comment:6 in reply to:  5 Changed 10 years ago by aguynamedryan+macports@…

Replying to zelegolas@…: You can get SANE to output a large amount of debug information by setting an environment variable before running scanadf. This is vaguely mentioned on the Maintainer's Site

export SANE_DEBUG_AVISION=127

If you suspect that scanadf is the problem, maybe the scanimage command will behave differently. Please note that scanimage doesn't do duplex scanning so I think you'll have to drop the "--source" argument when you run scanimage.

Changed 10 years ago by zelegolas@…

Attachment: scanadf.log added

scanadf (with export SANE_DEBUG_AVISION=127)

comment:7 Changed 10 years ago by zelegolas@…

I run the command

export SANE_DEBUG_AVISION=127
scanadf --source "ADF Duplex" --mode Gray --output-file "DocuMate262i/Page-%04d.ppm" --start-count 1

I put the log in attach. I hope it's will be help...

Changed 10 years ago by zelegolas@…

Attachment: scanimage.log added

comment:8 Changed 10 years ago by zelegolas@…

I try with scanimage: same behavior that scanadf (log file in attach)

comment:9 in reply to:  8 Changed 10 years ago by aguynamedryan+macports@…

Replying to zelegolas@…:

Thank you for the log files. I'm pretty sure the problem lies in the backend and not in scanimage or scanadf. There were a number of changes made to the avision backend between 1.0.21 and 1.0.22, several of which deal with paper feeding and ADF-type scanners, which is where your scanner seems to be running into problems. There have been no changes committed to the avision backend since the release of 1.0.22, so I have no patches for you to try.

You should file a bug report with the SANE project. I'd also recommend that you take a look at the backend/avision.c file in the sane-backends source code as that contains an email address for Mike, the current avision backend maintainer. He will probably be better able to help you than I at this point.

comment:10 Changed 4 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

Closing this ticket since the original issue was resolved.

Note: See TracTickets for help on using tickets.