Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#29359 closed defect (duplicate)

db46: error: jni.h: No such file or directory

Reported by: clang1234@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: db46

Description

When trying to install vim 7.3 with the python variant selected, i receive a failure. I have tried installing with +python, +python26, and +python27. Each failed. I ran "sudo port clean vim" after each failure. Installing vim with out a variant worked.

I have update mac ports to the latest version. Xcode is at version 3.2.3. My machine is OS X 10.6.7

Here is the output from running "sudo port install vim +python"

--->  Computing dependencies for vim
--->  Dependencies to be installed: python25 db46 gdbm openssl zlib readline sqlite3 tk Xft2 fontconfig freetype pkgconfig xrender xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python27 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto tcl xorg-libXScrnSaver xorg-libXext xorg-scrnsaverproto
--->  Building db46
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install db46
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: The following dependencies were not installed: python25 db46 gdbm openssl zlib readline sqlite3 tk Xft2 fontconfig freetype pkgconfig xrender xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-libxcb python27 xorg-libpthread-stubs xorg-xcb-proto libxml2 xorg-util-macros xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-renderproto tcl xorg-libXScrnSaver xorg-libXext xorg-scrnsaverproto
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (457.7 KB) - added by clang1234@… 8 years ago.
log file

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by clang1234@…

Attachment: main.log added

log file

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to blair@…
Port: db46 added; vim +python removed
Summary: Vim with Python Variant Fails to loaddb46: error: jni.h: No such file or directory

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #29115.

comment:3 in reply to:  description ; Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to clang1234@…:

I have update mac ports to the latest version. Xcode is at version 3.2.3. My machine is OS X 10.6.7

P.S: Please consider upgrading to Xcode 3.2.6.

comment:4 in reply to:  3 Changed 8 years ago by clang1234@…

Replying to ryandesign@…:

P.S: Please consider upgrading to Xcode 3.2.6.

Done. I tried install again and still failed. I'll take a better look at the ticket you've linked to and see if I've missed the fix in there. Any other suggestions? Thanks.

Note: See TracTickets for help on using tickets.