Opened 8 years ago

Closed 7 years ago

#29439 closed defect (fixed)

qfsm @0.52.0 Build failure during configuration using CMake (qmake not found)

Reported by: lee@… Owned by: har5ha
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: michaelld (Michael Dickens), ecronin (Eric Cronin)
Port: qfsm

Description

New install of qfsm. Fails during configuration claiming that QT qmake not found.

Mac OSX version: 10.6.7
XCode install version: 3.2.6 (1761)

Attachments (1)

qfsm_main.log (63.4 KB) - added by lee@… 8 years ago.
Log file of build

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by lee@…

Attachment: qfsm_main.log added

Log file of build

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to ecronin@…

comment:2 Changed 8 years ago by ecronin (Eric Cronin)

Cc: michaelld@… ecronin@… added
Owner: ecronin@… deleted

r69273 or r72633 removed the explicit qmake dependency, I don't know enough about the qt4 PortGroup to quickly fix this...

comment:3 Changed 8 years ago by michaelld (Michael Dickens)

I'll take a look at it in the next couple of days, since I wrote the Qt4 PortGroup.

comment:4 Changed 8 years ago by michaelld (Michael Dickens)

What does "port installed | grep qt4" return?

comment:5 Changed 7 years ago by jmroot (Joshua Root)

The problem here is that the qt4 portgroup adds a dependency on bin/qmake, which is also provided by qt3.

comment:6 Changed 7 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.