Opened 8 years ago

Closed 4 years ago

#29441 closed defect (wontfix)

dsniff-devel compiles but does not work on snow leopard

Reported by: tribes_email@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: dsniff-devel

Description

I've played with it for a few days, tried to compile my own version (I have tried 2.3 and 2.4b1) not matter what I always reproduce the same problem.

arpspoof works

but apps like dsniff, urlsnarf don't see anything on the network. They don't crash but never log anything. I think this is due to some snow leopard limitation for non blocking observation of the network. I'm not sure.

Change History (8)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Keywords: dsniff urlsnard libpcap libnet libnids removed
Port: dsniff-devel added

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Have you tried contacting the developer of dsniff about this? We have no maintainer for dsniff in MacPorts.

comment:3 Changed 8 years ago by jmroot (Joshua Root)

There doesn't appear to have been any upstream development since 2002.

comment:4 Changed 8 years ago by tribes_email@…

Exactly the development stopped a long a time ago so I guess it's over for dsniff support on snow leopard. Just by curiosity I compiled dsniff and ran it in a linux vmware on my macbook and it works ?! So there is definitely some incompatibility with osx. I tried briefly to debug the dsniff code. It appears dsniff does not receive any information so the problem probably lies in the lib it uses.

comment:5 Changed 8 years ago by tribes_email@…

It seems that drifnet faces the same problem. Does not crash but does not detect anything on the network. I think the only lib common to driftnet and dsniff is libpcap so maybe the problem lies here. So I guess any application using lipcap could have the same issue

comment:6 Changed 5 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to cal@…

comment:7 Changed 5 years ago by neverpanic (Clemens Lang)

I think I can reproduce this problem. However, I think the utilities are still useful, because they can still work on pcap dumps and some of the tools work. I'm not going to work on this for time reasons, but patches are welcome (I guess bugging upstream will get you nowhere, since development has ceased for years).

comment:8 Changed 4 years ago by neverpanic (Clemens Lang)

Resolution: wontfix
Status: newclosed

We will never fix this. This is an issue for upstream to fix, but upstream for dsniff or dsniff-devel is dead. If you'd like to take it over, please do so.

Note: See TracTickets for help on using tickets.