Opened 8 years ago

Closed 7 years ago

#29633 closed defect (duplicate)

opencv port installs python .so in wrong location

Reported by: stefan.walk@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: opencv

Description

I installed opencv with the +python27 variant, but it installs the python module in a directory named /opt/local/@@PYTHON_PKGD@@ (i guess a replacement went wrong).

It can be fixed by

/opt/local> sudo cp @@PYTHON_PKGD@@/cv.so Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/

but it's confusing at first.

Change History (3)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

I think this is a duplicate of #28332 which was resolved months ago. Please see if selfupdating and reinstalling the port works correctly.

sudo port selfupdate
sudo port -f uninstall opencv
sudo port install opencv

comment:2 Changed 8 years ago by stefan.walk@…

Yes, reinstalling did fix it. The other bug report does not contain the keywords i looked for :/

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.