Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#29663 closed defect (invalid)

git-core +universal fails with ppc on Snow Leopard

Reported by: robitaille@… Owned by: maccheck@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: git-core curl

Description

I started with a clean installation of macports and set the +universal flag to be a default in /opt/local/etc/macports/variants.conf

I also added ppc as an architecture in /opt/local/etc/macports/macports.conf for the universal_archs option

I then did sudo port install git-core and it installed all the dependencies first, and then crashes on git-core itself due to some issue with curl header files. The log file is attached.

Attachments (1)

main.log (53.4 KB) - added by robitaille@… 10 years ago.
Log file for 'sudo port install git-core'

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by robitaille@…

Attachment: main.log added

Log file for 'sudo port install git-core'

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to maccheck@…
Port: git-core curl added

Please remember to fill in the Port field and assign to the maintainer.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

git-core +universal works fine; I've used it that way for a long time. I'll bet the problem is that you added the ppc arch. Don't do that: you're on Snow Leopard, which doesn't run on PowerPC machines.

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Priority: HighNormal

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: git-core install fails when using +universal as default for all portsgit-core +universal fails with ppc on Snow Leopard
Note: See TracTickets for help on using tickets.