Opened 9 years ago

Closed 6 years ago

#29691 closed defect (wontfix)

python24: violation by /Users

Reported by: robitaille@… Owned by: jaroel (Roel Bruggink)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: python24

Description

I installed python24 and in the process got the following warning:

--->  Computing dependencies for python24
--->  Fetching python24
--->  Attempting to fetch Python-2.4.6.tar.bz2 from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/python24
--->  Verifying checksum(s) for python24
--->  Extracting python24
--->  Applying patches to python24
--->  Configuring python24
--->  Building python24
--->  Staging python24 into destroot
Warning: violation by /Users
Warning: python24 violates the layout of the ports-filesystems!
Warning: Please fix or indicate this misbehavior (if it is intended), it will be an error in future releases!
--->  Installing python24 @2.4.6_9+universal
--->  Activating python24 @2.4.6_9+universal

I don't get that warning with other python versions.

Attachments (1)

install24 (633.9 KB) - added by robitaille@… 9 years ago.
Log file for install

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

/Users doesn't appear in python24's contents for me. What files does it put in there for you?

comment:2 Changed 9 years ago by robitaille@…

It puts files inside ~/Library/Python/2.4 - I've attached a verbose log of the install to this ticket in case this helps. Note that this does not happen with python25, python26, or python27

Changed 9 years ago by robitaille@…

Attachment: install24 added

Log file for install

comment:3 Changed 9 years ago by robitaille@…

For info, I have a .pydistutils.cfg file that contains:

[install]
install_lib = ~/Library/Python/$py_version_short/site-packages
install_scripts = ~/usr/bin
install_data = ~/usr/share
install_headers = ~/usr/include

If I remove this file, then the install proceeds fine. The other python versions don't seem to be affected by this file, so I wonder why python24 is?

comment:4 Changed 9 years ago by blb@…

It's probably the --no-user-cfg option new in 2.7 (see http://bugs.python.org/issue1180) which has been back-ported to 2.5 and 2.6 for the ports.

If people really still care about 2.4 I guess someone would need to bring those patches to it as well.

comment:5 Changed 9 years ago by jmroot (Joshua Root)

This is technically a dupe of #9831. Nobody seemed to really care about 2.4 even back then, so the ticket was closed without backporting further than 2.5.

comment:6 Changed 6 years ago by jmroot (Joshua Root)

Resolution: wontfix
Status: newclosed

python24 is deprecated and scheduled to be removed in a couple of months.

Note: See TracTickets for help on using tickets.