Opened 10 years ago

Closed 10 years ago

#29821 closed enhancement (duplicate)

mercurial: allow using python27

Reported by: jowens@… Owned by: deric@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: mercurial

Description

I'm moving from python26 to python27 and am noting the packages that are hardcoded to python26 (googlecl, offlineimap, mercurial). Is it possible to make these packages dependent on a generic python? None of them seem to rely on too many python-version-specific features (gdata is ported to multiple python ports).

Attachments (1)

mercurial.diff (378 bytes) - added by macports@… 10 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to deric@…
Summary: python version independence? possible?mercurial: allow using python27
Type: requestenhancement
Version: 1.9.2

Please remember to cc the maintainer. As per the ticket guidelines, the 'request' ticket type is for requesting new ports.

comment:2 Changed 10 years ago by macports@…

Oops, forgot to search for existing when filing multiple tickets and made a dupe #30255

Since that is closed, attaching the patch from it here in hopes its useful. Its trivial, but maybe someone can just commit it and we can move on.

Changed 10 years ago by macports@…

Attachment: mercurial.diff added

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #27757.

Note: See TracTickets for help on using tickets.