Opened 6 years ago

Closed 6 years ago

#29889 closed submission (fixed)

ola @0.8.9 New Port Submission

Reported by: p3k (Tobi Schäfer) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: nomis52@…
Port: ola

Description

I created a new port for OLA, an open framework for DMX lighting control and kindly ask for inclusion in the MacPorts port collection.

Please refer to the attached Portfile for details.

Attachments (3)

Portfile (1.9 KB) - added by p3k (Tobi Schäfer) 6 years ago.
Portfile for OLA 0.8.9
Portfile.2 (1.5 KB) - added by ryandesign (Ryan Schmidt) 6 years ago.
revised portfile proposal
main.log (114.6 KB) - added by ryandesign (Ryan Schmidt) 6 years ago.
log of build failure

Download all attachments as: .zip

Change History (17)

Changed 6 years ago by p3k (Tobi Schäfer)

Portfile for OLA 0.8.9

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • Owner changed from macports-tickets@… to ryandesign@…
  • Status changed from new to assigned

Thanks.

Changed 6 years ago by ryandesign (Ryan Schmidt)

revised portfile proposal

Changed 6 years ago by ryandesign (Ryan Schmidt)

log of build failure

comment:2 follow-up: Changed 6 years ago by ryandesign (Ryan Schmidt)

I've attached a revised portfile that has the following changes:

  • changed from 3-spaces-per-indent to 4-spaces-per-indent
  • added standard modeline
  • removed md5 checksum
  • simplified master_sites
  • pkgconfig is a build dependency not a lib dependency
  • removed commented-out i386 variant; if the user wants an i386 build, the user shall set "build_arch i386" in macports.conf
  • simplified http variant and brought remaining code from pre-configure block into main part of portfile
  • removed test phase override; just set the test variables in main part of portfile

I also commented out the use of autoreconf because I couldn't determine why it was being used, and the port behaves the same for me whether or not it runs autoreconf. If there was a specific reason why you wanted to autoreconf, let me know.

I'm not committing it yet because it doesn't build (any ideas why not?):

CID.cpp: In member function 'void ola::plugin::e131::CID::Pack(uint8_t*) const':
CID.cpp:67: error: invalid static_cast from type 'char**' to type 'void**'
CID.cpp: In member function 'std::string ola::plugin::e131::CID::ToString() const':
CID.cpp:104: error: invalid static_cast from type 'char**' to type 'void**'
make[4]: *** [libolae131core_la-CID.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

comment:3 Changed 6 years ago by p3k (Tobi Schäfer)

Thanks for the valuable feedback and the revised Portfile – I am now aware I should have asked for some feedback first, anyway...

Regarding the autoreconf issue and the cause for not compiling I am going to ask the maintainer since I am just organising the Portfile.

comment:4 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by ryandesign (Ryan Schmidt)

The build failure appears to be because I have ossp-uuid installed; deactivating it makes the build succeed. Need to investigate how to tell ola not to use ossp-uuid even if it is installed.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

I have now looked at their Mac OS X build instructions; they probably suggested you run autoreconf because you started with a git checkout, which wouldn't have the generated autoconf files. But here we're building from a source tarball, and the autoconf files have already been generated for us in the process of packing up that tarball. So I think we can skip autoreconf.

comment:6 in reply to: ↑ 4 Changed 6 years ago by p3k (Tobi Schäfer)

Replying to ryandesign@…:

The build failure appears to be because I have ossp-uuid installed; deactivating it makes the build succeed. Need to investigate how to tell ola not to use ossp-uuid even if it is installed.

I see. This issue should be solved but the fix is yet to arrive in a package:

https://groups.google.com/d/msg/open-lighting/fMyLo2K5NWQ/lElA7kBN7nUJ

Could an additional “conflicts” declaration be used in this case for now?

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

I committed my version of the port in r79629, with these additional changes:

  • indicated which version of the LGPL this software is under
  • disabled libusb, since I noticed it linked with the libusb I had installed (if USB support is desired it can be added back in, with a dependency on libusb)

The "conflicts" declaration models install-time conflicts (multiple ports that want to install files of the same name); it does not model build-time conflicts like this problem. I'll see if I can find the commit in which they fixed the problem, and apply it to the port.

comment:8 follow-up: Changed 6 years ago by p3k (Tobi Schäfer)

Thanks for your help and for committing the Portfile! :)

When will a newly committed Portfile generally become available in a MacPorts installation?

Oh, and could you please also take a look at #29890? The OLA examples go hand in hand with OLA...

comment:9 in reply to: ↑ 8 Changed 6 years ago by ryandesign (Ryan Schmidt)

The rsync server syncs with the Subversion repository every half hour, so it should be available momentarily.

Yes I'll look at the ola-examples too.

comment:10 Changed 6 years ago by ryandesign (Ryan Schmidt)

I just noticed the email address in the maintainers field of the portfile is not the same as the email address in the reporter field of this ticket. These are both email addresses for you?

comment:11 Changed 6 years ago by p3k (Tobi Schäfer)

No, I was not sure whether to add my address to the maintainers declaration because I only organise the Portfile. Meanwhile, Simon Newton (who develops OLA and owns the address in the Portfile) considered to include it. I already did so in the Portfile for the OLA Examples (#29890).

comment:12 Changed 6 years ago by nomis52@…

  • Cc nomis52@… added

Cc Me!

comment:13 Changed 6 years ago by nomis52@…

Sorry, this moved much faster than I expected. I have some edits to the port file but I'll open a separate ticket for those. I'd like it if both interface@… and myself can be listed as maintainers.

Also I'm about to build a new release so there isn't much point in trying to apply the patches. It should be out today or tomorrow.

Simon

comment:14 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to fixed
  • Status changed from assigned to closed

The maintainers line lists the person who is responsible for the portfile. Usually this is not the upstream developer of the software (who may not even know MacPorts exists), though in this case I see Simon would like to maintain it, so we'll do that. I added the second maintainer in r79631. I'll close this ticket now; new tickets can be filed for new issues.

Note: See TracTickets for help on using tickets.