Opened 10 years ago

Closed 10 years ago

#29960 closed defect (fixed)

bibutils compiles for hardcoded architectures i386+ppc

Reported by: chris@… Owned by: jochen@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: drkp (Dan Ports)
Port: bibutils

Description (last modified by jmroot (Joshua Root))

sudo port install bibutils

Install fails

--->  Staging bibutils into destroot
Error: Target org.macports.destroot returned: shell command failed (see log for details)
Log for bibutils is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_bibutils/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log shows that it is trying to use the powerpc version of llvm

:info:destroot llvm-gcc-4.2: error trying to exec '/usr/bin/../llvm-gcc-4.2/bin/powerpc-apple-darwin10-llvm-gcc-4.2': execvp: No such file or directory

This is an Intel architecture mac without the powerpc compiler installed, so it fails.

I haven't asked it to produce a universal binary, or to my knowledge changed any settings that might suggest to it that I want a universal binary.

Attachments (2)

configure.patch (447 bytes) - added by chris@… 10 years ago.
Portfile.patch (1.7 KB) - added by drkp (Dan Ports) 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to jochen@…

Please remember to preview and use WikiFormatting, and to cc the maintainer.

comment:2 Changed 10 years ago by jochen@…

Resolution: worksforme
Status: newclosed

It works for me (both with 4.3 and with the new version 4.12 to which I just upgraded). I am using gcc and have no idea what the problem with llvm might be. Please ask on the respective mailing lists (macports-dev, llvm, ?). Sorry.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: closedreopened
Summary: bibutils does not compile - wrong architecture?bibutils compiles for hardcoded architectures i386+ppc

I can confirm that this builds universal i386/ppc no matter what arch(s) you have configured.

comment:4 Changed 10 years ago by chris@…

I'm sure that it works fine for jochen and many others - provided that they have the PowerPC version of llvm gcc installed, but many other people won't. Also, it's suboptimal for me, as it could compile for x86_64 instead of i386 on my system, but as said it's hard coded.

comment:5 Changed 10 years ago by jochen@…

Okay... This is apparently hardcoded in the bibutils build process, as there is nothing in the (simple) Portfile to force this. Unfortunately I do not have time to look at this.

The port is openmaintainer, so please feel free to fix it if it is important for you. If somebody volunteers to take over maintainership, I am also happy to transfer it.

Sorry for not being more helpful, but that's what you get. Jochen

Changed 10 years ago by chris@…

Attachment: configure.patch added

comment:6 Changed 10 years ago by chris@…

I've uploaded a patch. The configure script that the developer has written assumes that it's always possible to build a universal. Since we don't need universal builds at all on MacPorts (I'm guessing, I don't really know, do we?) this patch just disables this. I'm sending it upstream as well.

Sorry, I would patch the port file but I don't know the MacPorts internals at all.

comment:7 Changed 10 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:8 Changed 10 years ago by drkp (Dan Ports)

This could be a more serious problem on Lion, where PPC support isn't available. It's also not UsingTheRightCompiler.

How about patching the portfile like this? I was going to patch the configure script, but the script is simple enough that it would have meant replacing pretty much all of it; this seemed easier. It uses the right compiler and cflags, and builds for the requested arch (including +universal).

If no objections, I'll commit it.

Changed 10 years ago by drkp (Dan Ports)

Attachment: Portfile.patch added

comment:9 in reply to:  8 Changed 10 years ago by jochen@…

Please go ahead.

You might also consider to take over maintainership...

Jochen

comment:10 Changed 10 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.