Opened 16 years ago

Closed 16 years ago

Last modified 12 years ago

#2998 closed defect (fixed)

[Port Abandoned] libcompat

Reported by: joelmichael@… Owned by: eric@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: bahamat@…, osx@…
Port: libcompat

Description (last modified by mf2k (Frank Schima))

I tried to install fortune via "port install fortune". libcompat is a dependency of fortune. My Darwin Ports is installed in /usr/ports. Here is the text of the error:

chappi:~ joel$ port install fortune
--->  Building libcompat with target all
Error: Target com.apple.build returned: shell command "cd "/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat" && LDADD=-install_name\ /usr/ports/lib/libcompat.1.dylib bsdmake all" returned 
error 1
Command output: Warning: Object directory not changed from original /usr/ports/var/db/dports/
build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat
cc -O -pipe   -DLIBC_SCCS -DSYSLIBC_SCCS -I/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/../libc/locale -fno-common  -c /usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c
/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c:50:20: error: regexp.h: No such file or directory
/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c:55: error: parse error before '*' token
/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c:55: warning: data definition has no type or storage class
/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c: In function 're_comp':
/usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat/4.3/regex.c:73: warning: assignment makes pointer from integer without a cast
*** Error code 1

Stop in /usr/ports/var/db/dports/build/
file._usr_ports_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/
work/libcompat.

Error: The following dependencies failed to build: libcompat

Attachments (1)

libcompat.tgz (2.1 KB) - added by pguyot (Paul Guyot) 16 years ago.
Fix for Tiger

Download all attachments as: .zip

Change History (14)

comment:1 Changed 16 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to eric@…

Assign but to maintainer.

comment:2 Changed 16 years ago by mww@…

Summary: libcompat does not compileBUG: libcompat does not compile

comment:3 Changed 16 years ago by mww@…

Cc: bahamat@… added

comment:4 Changed 16 years ago by mww@…

* Bug 3012 has been marked as a duplicate of this bug. *

comment:5 Changed 16 years ago by coppola@…

Same problem when rebuilding emacs21-21.3.50 ; (missing dlcompat_dev) As a _temporary workaround_ I have used this

gcc_select 3.3 fink install dlcompat_dev gcc_select 4.0 fink install emacs21

It produces a library version that lets emacs build succeed, emacs actually works with X11 (not thoroughfully tested yet, but it compiles some tex, opens frames and launches xdvi).

Changed 16 years ago by pguyot (Paul Guyot)

Attachment: libcompat.tgz added

Fix for Tiger

comment:6 Changed 16 years ago by pguyot (Paul Guyot)

blocked: 3124

comment:7 Changed 16 years ago by osx@…

Cc: osx@… added

comment:8 Changed 16 years ago by osx@…

* Bug 3153 has been marked as a duplicate of this bug. *

comment:9 Changed 16 years ago by joelmichael@…

Someone posted a fix for this on May 17th. It's now July 12th. Could the maintainer please push the fix into the release?

comment:10 Changed 16 years ago by pguyot (Paul Guyot)

Summary: BUG: libcompat does not compile[Port Abandoned] libcompat

I'm committing the fix and resetting the maintainer to darwinports@….

comment:11 Changed 16 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: newclosed

comment:12 Changed 12 years ago by nerdling (Jeremy Lavergne)

Description: modified (diff)
Port: libcompat added

comment:13 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Note: See TracTickets for help on using tickets.