Opened 16 years ago

Closed 16 years ago

#3001 closed defect (fixed)

BUG: kermit fails to install

Reported by: bahamat@… Owned by: daved@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: daved@…
Port:

Description

Output:

$ port install minicom ---> Fetching kermit ---> Verifying checksum(s) for kermit ---> Extracting kermit ---> Applying patches to kermit ---> Configuring kermit ---> Building kermit with target macosx102nc Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_comms_kermit/work/" && make macosx102nc" returned error 2 Command output: ckcnet.c:13411: error: redefinition of 'type' ckcnet.c:13192: error: previous definition of 'type' was here ckcnet.c:13411: error: subscripted value is neither array nor pointer ckcnet.c:13411: error: subscripted value is neither array nor pointer ckcnet.c:13411: warning: data definition has no type or storage class ckcnet.c:13411: error: parse error before '+=' token ckcnet.c:13415: error: redefinition of 'class' ckcnet.c:13195: error: previous definition of 'class' was here ckcnet.c:13415: error: subscripted value is neither array nor pointer ckcnet.c:13415: error: subscripted value is neither array nor pointer ckcnet.c:13415: warning: data definition has no type or storage class ckcnet.c:13415: error: parse error before '+=' token ckcnet.c:13420: error: redefinition of 'rdlen' ckcnet.c:13198: error: previous definition of 'rdlen' was here ckcnet.c:13420: error: subscripted value is neither array nor pointer ckcnet.c:13420: error: subscripted value is neither array nor pointer ckcnet.c:13420: warning: data definition has no type or storage class ckcnet.c:13420: error: parse error before '+=' token ckcnet.c:13435: error: initializer element is not constant ckcnet.c:13435: warning: data definition has no type or storage class ckcnet.c:13436: error: parse error before "if" ckcnet.c:13438: error: parse error before '*' token ckcnet.c:13438: error: parse error before ')' token ckcnet.c:13439: error: variable-size type declared outside of any function ckcnet.c:13439: error: conflicting types for 'retstr' ckcnet.c:13435: error: previous definition of 'retstr' was here ckcnet.c:13439: warning: data definition has no type or storage class ckcnet.c:13441: error: parse error before "if" make[1]: * [ckcnet.o] Error 1 make: * [macosx102nc] Error 2

Error: The following dependencies failed to build: kermit lrzsz

Attachments (1)

kermit.patch (311 bytes) - added by daved@… 16 years ago.
Patch to make kermit compile on 10.4

Download all attachments as: .zip

Change History (13)

comment:1 Changed 16 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to daved@…

Assigning bug to port miantainer.

-jmpp

Changed 16 years ago by daved@…

Attachment: kermit.patch added

Patch to make kermit compile on 10.4

comment:2 Changed 16 years ago by daved@…

Status: newassigned

comment:3 Changed 16 years ago by mww@…

Summary: kermit fails to installBUG: kermit fails to install

comment:4 Changed 16 years ago by daved@…

Owner: changed from daved@… to darwinports-bugs@…
Status: assignednew

comment:5 Changed 16 years ago by jmpp@…

Cc: daved@… added

May I ask why you gave up this bug Dave? After all, you're the maintainer of the port...

-jmpp

comment:6 Changed 16 years ago by daved@…

Doh! Forgot to add comment. Forgot to add the comment asking for the patch to be committed. I didn't see anything on the user guide on the subject.

comment:7 Changed 16 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to daved@…

If I catch anyone with a copy of Tiger I'll ask them to test the patch, submit the changes and close the bug. But in any case you should not drop bugs assigned to you even upon their resolution (the database is searchable, so we need it for our history and sorting), unless you're planning on dropping the port. But as I imagine that's not the case, I'm reassigning this once again to you and asking you to please keep it. Thanks!

-jmpp

comment:8 Changed 16 years ago by bahamat@…

(In reply to comment #5)

If I catch anyone with a copy of Tiger I'll ask them to test the patch, submit

the changes and close the

bug.

FWIW, I submitted the bug originally, and I'm using Tiger. I've applied the patch manually and it worked as advertised.

comment:9 Changed 16 years ago by segr@…

I also was having the same problem on my 10.4.1 system and the patch allowed me get kermit installed. Thanks for the great work, I suspect the patch is good to be commited.

comment:10 Changed 16 years ago by sean@…

I just installed DarwinPorts and did a selfupdate; this patch doesn't seem to have made its way into the tree yet. Just as an FYI, I appled the patch manually and everything compiled fine. :)

comment:11 Changed 16 years ago by exile@…

The attached patch has been confirmed on 10.4, please submit this.

comment:12 Changed 16 years ago by daved@…

Resolution: fixed
Status: newclosed

Someone else has committed a fix for the problem. No discussion with current maintainer was done. They didn't even bother to close this bug report. For the record, I am not upset with the fix (it was better) but that no discussion happened. Since I have very little time and others seem to able to deal with these issues, I will be submitting bugs to remove me as the maintainer.

Note: See TracTickets for help on using tickets.