Opened 10 years ago

Closed 10 years ago

#30135 closed defect (duplicate)

cairo: cairo-fdr.a differs and cannot be merged

Reported by: shirocov@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: cairo

Description (last modified by ryandesign (Ryan Schmidt))

port install cairo
--->  Computing dependencies for cairo
--->  Staging cairo into destroot
Error: Target org.macports.destroot returned: error copying "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/work/destroot" to "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/work/destroot-x86_64/destroot": file already exists
Log for cairo is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (3)

i386 cairo-fdr.a (13.4 KB) - added by shirocov@… 10 years ago.
x86_64 cairo-fdr.a (13.6 KB) - added by shirocov@… 10 years ago.
main.log (564.9 KB) - added by shirocov@… 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Milestone: MacPorts 2.0.0
Owner: changed from macports-tickets@… to ryandesign@…
Port: cairo added

So clean and try again.

sudo port clean cairo

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: cairo into destrootcairo: error copying destroot: file already exists

comment:3 Changed 10 years ago by shirocov@…

sh-3.2# port clean cairo
--->  Cleaning cairo
sh-3.2# port install cairo
--->  Computing dependencies for cairo
--->  Fetching archive for cairo
--->  Fetching cairo
--->  Verifying checksum(s) for cairo
--->  Extracting cairo
--->  Configuring cairo
--->  Building cairo
--->  Staging cairo into destroot
Error: Target org.macports.destroot returned: /opt/local/lib/cairo/cairo-fdr.a differs in /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/work/destroot-i386 and /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/work/destroot-x86_64 and cannot be merged
Log for cairo is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_cairo/cairo/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

new bug after cleaning cairo(

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Please remember to use WikiFormatting.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: cairo: error copying destroot: file already existscairo: cairo-fdr.a differs and cannot be merged

I understand that cairo-fdr.a would differ between the two destroots; that's normal and expected: one of them should be built for i386 and the other should be built for x86_64. What I don't understand is why they can't be merged; lipo should have had no problem doing so. Can you please attach the two cairo-fdr.a files (from the two indicated destroot directories) so I can take a look at them?

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Can you also attach the main.log referenced above? Maybe it contains more relevant details.

Changed 10 years ago by shirocov@…

Attachment: i386 cairo-fdr.a added

Changed 10 years ago by shirocov@…

Attachment: x86_64 cairo-fdr.a added

Changed 10 years ago by shirocov@…

Attachment: main.log added

comment:7 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

A-ha, you're using llvm-gcc-4.2. Duplicate of #29842.

comment:8 Changed 10 years ago by shirocov@…

Resolution: duplicate
Status: closedreopened
port install llvm-gcc42
--->  Computing dependencies for llvm-gcc42
--->  Dependencies to be installed: gmp gmp ld64 llvm libffi mpfr


-->  Building llvm-gcc42
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for llvm-gcc42 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_llvm-gcc42/llvm-gcc42/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

I have no llvm-gcc42 in my system(

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed

I didn't say anything about the llvm-gcc42 port. I was referring to the line in the log that says "Using compiler 'Mac OS X llvm-gcc 4.2'" which indicates this port is compiling using the llvm gcc 4.2 provided by Xcode.

Note: See TracTickets for help on using tickets.