Opened 9 years ago

Closed 9 years ago

#30147 closed defect (fixed)

soprano fails to build with raptor2

Reported by: nerdling (Jeremy Lavergne) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.99
Keywords: Cc: ryandesign (Ryan Schmidt), michaelld (Michael Dickens), drkp (Dan Ports), kurtjaeke@…, pixilla (Bradley Giesbrecht), nerdling (Jeremy Lavergne), mkae (Marko Käning), fcasarramona
Port: redland soprano

Description

I'm trying to build soprano on top of redland but it complains that just about everything in redland's include/ are with error.

Build log from soprano attached.

Thoughts?

Attachments (2)

soprano.log (516.7 KB) - added by nerdling (Jeremy Lavergne) 9 years ago.
debug build log from soprano
patch-redland.diff (2.4 KB) - added by pixilla (Bradley Giesbrecht) 9 years ago.
Fix redland headers.

Download all attachments as: .zip

Change History (26)

Changed 9 years ago by nerdling (Jeremy Lavergne)

Attachment: soprano.log added

debug build log from soprano

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

I assume this is more raptor/raptor2 conflict. Look at the pre-configure block of the redland port for how I worked around it. I'm not sure what the best real solution would be.

comment:2 Changed 9 years ago by nerdling (Jeremy Lavergne)

Unfortunately, soprano's configure requires raptor.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Oh I see. Does deactivating raptor2 help anything then?

I had to do some irritating massaging to raptor2 to get it to install alongside raptor and it doesn't appear to have been 100% successful.

comment:4 Changed 9 years ago by nerdling (Jeremy Lavergne)

I take that back, there are flags to disable it--it's simply on by default.

Let me also try raptor2. It wasn't installed at the time I received the error so perhaps I'm using the wrong one?

comment:5 Changed 9 years ago by nerdling (Jeremy Lavergne)

Switching raptor2 for raptor does not help, however disabling the raptor parser/serializer in addition to disabling redland let's me get by the problems.

-- Soprano Components that will NOT be built:
   * Redland storage backend (missing librdf/redland - http://librdf.org)
   * Raptor RDF parser (missing libraptor - http://librdf.org)
   * Raptor RDF serializer (missing libraptor - http://librdf.org)

This still leaves me wonder is actually wrong here. Ryan, would you like the ticket left open?

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

If the issue is not resolved, the ticket should stay open. I however have no idea what to do about it.

comment:7 Changed 9 years ago by kurtjaeke@…

See #30191 and #30068 for a fix which works for me. Apparently, changeset #80426 was a too easy fix, KDE needs the semantic stuff components.

comment:8 Changed 9 years ago by kurtjaeke@…

Cc: kurtjaeke@… added

Cc Me!

comment:9 Changed 9 years ago by kurtjaeke@…

Please try the following:

  • re-enable the semantic components in the Portfiles of soprano and kdepimlibs (patches provided, see attachments of #30068)
  • apply the patch to soprano (also see attachments of #30068)
  • rebuild kdelibs4 and kdepimlibs4
  • build a KDE application, see if this works out (see #30191)

Changed 9 years ago by pixilla (Bradley Giesbrecht)

Attachment: patch-redland.diff added

Fix redland headers.

comment:10 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Redland headers fix r80889.

comment:11 Changed 9 years ago by nerdling (Jeremy Lavergne)

soprano redland/raptor support re-enabled in r80914.

comment:12 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Summary: redland producing invalid header files?soprano fails to build with raptor2

Soprano IS NOT compatible with raptor2.
Soprano IS NOT compatible with redland or rasqal BUILT WITH raptor2.
Raptor2 IS NOT ABI compatible with raptor1, see Changes between raptor2 1.4.21 and 2.0.0.
For an ongoing KDE effort to have soprano support raptor2 see Support for Raptor2.

Until soprano is compatible with raptor2 via release or patches, we should downgrade rasqal and redland and reenable redland in soprano.

www/rasqal: 
	downgrade to 0.9.21
		svn merge -r80050:r74576 www/rasqal/Portile
	add epoch
www/redland: 
	downgrade to 1.0.12
		svn merge -r80050:r73785 www/redland/Portile
	add epoch
devel/soprano
	re-enable raptor and redland

comment:13 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Cc: pixilla@… added

Cc Me!

comment:14 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Cc: snc@… mk@… added

comment:15 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Soprano raptor2 support may be just around the corner! see KDE SUPPORT - SOPRANO

comment:16 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Looks like soprano version 2.6.52 is being readied for release. I'm building the git version now and will report back.

comment:17 Changed 9 years ago by pixilla (Bradley Giesbrecht)

Soprano from git compiled with raptor2 for me.
The CMakeLists.txt from git shows a soprano version bump to 2.6.52, but no official release yet.
I am now building some ports that use soprano and will see if they work. If all tests are good and an official soprano 2.6.52 has not been released, I will add a patch to MacPorts soprano 2.6.51 bringing it on par with current git.
Any better ideas out there?

comment:18 Changed 9 years ago by nerdling (Jeremy Lavergne)

As long as it's a commit tag, sounds good.

comment:19 in reply to:  18 Changed 9 years ago by gleirsch@…

I'm not sure. I just did a port selfupdate and an upgrade outdated. As part of that, soprano did'nt build. The logs tell me about a shell script failure:

:info:build /opt/local/bin/cmake -E cmake_progress_report /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work
/build/CMakeFiles  52 53 54 55 56 57 58 59
:info:build [ 56%] Built target soprano_virtuosobackend
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/work/build" && /usr/bin/make -j4 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for soprano): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for soprano is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_soprano/soprano/main.log

comment:20 Changed 9 years ago by gleirsch@…

Unfortunately, I couldn't find the shell logs.

comment:21 Changed 9 years ago by mkae (Marko Käning)

Watch out for the last line. That's where the path to the build log is printed. Check it out!

comment:22 in reply to:  17 Changed 9 years ago by nerdling (Jeremy Lavergne)

Replying to pixilla@…:

Soprano from git compiled with raptor2 for me.

Can you post your patches and/or email them? Thanks.

Also, just a note for whomever is the one that commits the soprano change: revbump all 4.6.5 KDE packages.

comment:23 Changed 9 years ago by fcasarramona

Cc: ferran.casarramona@… added

Cc Me!

comment:24 Changed 9 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: newclosed

The next release of soprano addresses these issues. Making use of git branch until they release a tarball. r81070.

Note: See TracTickets for help on using tickets.