Opened 10 years ago

Closed 9 years ago

#30188 closed defect (worksforme)

libpaper: configure hangs

Reported by: zouhu0628@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: libpaper

Description

I am installing the gnudatalanguage, and it needs libpaper when configuring libpaper, it keeps the configuring status. command: sudo port install libpaper The installing runs for a night and it keeps configuring as it is dead? Do anyone encounter this problem, any solution? Note: the port didn't compelete and no log file was created!

Attachments (1)

main.log (4.0 KB) - added by zouhu0628@… 10 years ago.
now i get the main log

Download all attachments as: .zip

Change History (8)

comment:1 in reply to:  description Changed 10 years ago by zouhu0628@…

Replying to zouhu0628@…:

I am installing the gnudatalanguage, and it needs libpaper when configuring libpaper, it keeps the configuring status. command: sudo port install libpaper The installing runs for a night and it keeps configuring as it is dead? Do anyone encounter this problem, any solution? Note: the port didn't compelete and no log file was created!

PS: and when I click other applications, I was warned that "Unable to fork. "

Changed 10 years ago by zouhu0628@…

Attachment: main.log added

now i get the main log

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Port: libpaper added
Summary: install libpaper: deadlibpaper: configure hangs

Please remember to fill in the Port field.

If I understand you correctly, the configure phase is hanging? What "other applications" are giving you the warning message you mention in comment:1? What do you mean when you say you "click" them? Are you launching them? Activating them when they are already open? Clicking on a GUI element in them?

comment:3 Changed 10 years ago by zouhu0628@…

Yes, the configure phase is hanging. And whatever other applicate I want to run or lauch, I was prompted that "unable to fork",(not only gui application, but also commands in the terminal). What is the problem?

comment:4 in reply to:  2 Changed 10 years ago by zouhu0628@…

Replying to jmr@…:

Please remember to fill in the Port field.

And I am sorry to make some trouble since I am a newer at this website

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Do these problems remain after you restart your computer? It sounds like there are just too many things going on on your computer, such that there are no resources available to "fork" a new process.

comment:6 in reply to:  5 Changed 10 years ago by zouhu0628@…

Replying to ryandesign@…:

yes, the problems still exist. I think they happened in the port process. Whenever it is configuring the libpaper, the problems occur. I don't know what is the problem?

Do these problems remain after you restart your computer? It sounds like there are just too many things going on on your computer, such that there are no resources available to "fork" a new process.

comment:7 Changed 9 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

I can't reproduce this. If there's not something wrong with your system, there's at least something significantly different about it, so unfortunately it's not really possible for someone else to debug this for you. At least there's a prebuilt package available these days, so you should be able to just install from that without configuring libpaper yourself.

Note: See TracTickets for help on using tickets.