Opened 9 years ago

Closed 8 years ago

#30197 closed defect (worksforme)

vim @7.3.237_0 fails to build

Reported by: ksze (Kal Sze) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: build failure Cc:
Port: vim

Description

vim @7.3.237_0+cscope+gtk2+huge+nls+perl+python31+ruby+tcl+x11+xim

Apparently the object files could not be linked.

The --with-xim configure option also seems to be unrecognized.

Complete build log attached.

Attachments (1)

main.log (351.9 KB) - added by ksze (Kal Sze) 9 years ago.
Build log

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by ksze (Kal Sze)

Attachment: main.log added

Build log

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Cc: raimue@… removed
Owner: changed from macports-tickets@… to raimue@…

comment:2 Changed 9 years ago by raimue (Rainer Müller)

Status: newassigned

Variant +xim fixed in r80970.

comment:3 Changed 8 years ago by jmroot (Joshua Root)

Is this still a problem with 7.3.496?

comment:4 Changed 8 years ago by ksze (Kal Sze)

The problem seems to be gone. I just successfully built and installed with +perl.

comment:5 Changed 8 years ago by ksze (Kal Sze)

But of course, I'm using Mac OS X Lion with MacPorts 2.0.4 now, instead of Mac OS X Snow Leopard and MacPorts 1.9.2 like 10 months ago. Not sure if it has anything to do with the problem.

comment:6 Changed 8 years ago by raimue (Rainer Müller)

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.