Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#30272 closed defect (fixed)

wxWidgets failes on 10.7

Reported by: marc.schlaich@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.0.99
Keywords: lion Cc: dmirkitanov@…, ironstorm@…
Port: wxWidgets

Description

Compiling wxWidgets fails on Mac OS X 10.7 Lion.

Attachments (1)

main.log (67.1 KB) - added by marc.schlaich@… 9 years ago.

Download all attachments as: .zip

Change History (11)

Changed 9 years ago by marc.schlaich@…

Attachment: main.log added

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Cc: jwa removed
Owner: changed from macports-tickets@… to jwa@…

trac requires complete email addresses.

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Keywords: lion added

comment:3 Changed 9 years ago by dmirkitanov@…

Cc: dmirkitanov@… added

Cc Me!

comment:4 Changed 9 years ago by userxmirc@…

In configure.args in the Portfile file add --with-macosx-sdk=/Developer/SDKs/MacOSX10.6.sdk --with-macosx-version-min=10.6

Using Xcode 4.1 and Lion

It works.

comment:5 in reply to:  4 Changed 9 years ago by marc.schlaich@…

Replying to userxmirc@…:

In configure.args in the Portfile file add --with-macosx-sdk=/Developer/SDKs/MacOSX10.6.sdk --with-macosx-version-min=10.6

Using Xcode 4.1 and Lion

It works.

I can confirm this. Thanks!

comment:6 Changed 9 years ago by ajb78@…

I can confirm that this works for me with wxWidgets-devel on Lion with Xcode 4.1 on i5 mac.

comment:7 Changed 9 years ago by jyrkiwahlstedt

Resolution: fixed
Status: newclosed

Patch added, thanks, in r81354...

comment:8 in reply to:  4 Changed 9 years ago by lucaghera8@…

It works also with wxWidgets-python

Replying to userxmirc@…:

In configure.args in the Portfile file add --with-macosx-sdk=/Developer/SDKs/MacOSX10.6.sdk --with-macosx-version-min=10.6

Using Xcode 4.1 and Lion

It works.

comment:9 Changed 8 years ago by benedikt@…

Same issue here on Mountain Lion, but I just removed the /Developer folder due to some other build issues. Any ideas?

comment:10 Changed 8 years ago by ironstorm@…

Cc: ironstorm@… added

Cc Me!

Note: See TracTickets for help on using tickets.