Opened 15 years ago

Closed 15 years ago

#3031 closed defect (fixed)

BUG: ettercap-ng fails to build

Reported by: voorhees@… Owned by: ultrix@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: gunnmjk@…, unlucio@…
Port:

Description

ettercap-ng fails to build:

powerpc-apple-darwin8-gcc-4.0.0: unrecognized option `-pthread' /usr/bin/ld: warning -L: directory name (/opt/local/src) does not exist /usr/bin/ld: warning prebinding disabled because dependent library: /opt/local/lib/libpcre.0.dylib is not prebound /usr/bin/ld: Undefined symbols: _res_9_dn_expand collect2: ld returned 1 exit status make[2]: * [ettercap] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive] Error 1

Attachments (3)

Portfile.diff (732 bytes) - added by ultrix@… 15 years ago.
Portfile patch
patch-src-Makefile.in (780 bytes) - added by ultrix@… 15 years ago.
Updated Makefile.in patch
patch-configure (452 bytes) - added by ultrix@… 15 years ago.
Configure patch

Download all attachments as: .zip

Change History (17)

comment:1 Changed 15 years ago by opendarwin.org@…

Status: newassigned

comment:2 Changed 15 years ago by snu@…

Summary: ettercap-ng fails to buildBUG: ettercap-ng fails to build

comment:3 Changed 15 years ago by jason.botwick@…

I also found that this did not build, but on 10.3.9:

Let me know if I can provide more info at jason.botwick@…

---> Building ettercap-ng with target all Making all in man make[1]: Nothing to be done for `all'. Making all in share make[1]: Nothing to be done for `all'. Making all in include make all-am make[2]: Nothing to be done for `all-am'. Making all in include make all-am make[2]: Nothing to be done for `all-am'. Making all in src Making all in os if gcc -DHAVE_CONFIG_H -I. -I. -I../../include -O2 -funroll-loops -fomit-frame-pointer -Wall -I/ opt/local/include -I/opt/local/include -I/opt/local/include -I/opt/local/include -g -O2 -MT libec_os_a-ec_darwin.o -MD -MP -MF ".deps/libec_os_a-ec_darwin.Tpo" -c -o libec_os_a-ec_darwin.o test -f 'ec_darwin.c' || echo './'ec_darwin.c; \ then mv -f ".deps/libec_os_a-ec_darwin.Tpo" ".deps/libec_os_a-ec_darwin.Po"; else rm -f ".deps/ libec_os_a-ec_darwin.Tpo"; exit 1; fi In file included from ../../include/ec_resolv.h:12,

from ../../include/ec_profiles.h:8, from ../../include/ec_packet.h:8, from ../../include/ec_sniff.h:7, from ../../include/ec_globals.h:7, from ../../include/ec.h:54, from ec_darwin.c:21:

/usr/include/arpa/nameser_compat.h:99: error: conflicting types for `HEADER' /usr/include/arpa/nameser.h:304: error: previous declaration of `HEADER' In file included from ../../include/ec_resolv.h:14,

from ../../include/ec_profiles.h:8, from ../../include/ec_packet.h:8, from ../../include/ec_sniff.h:7, from ../../include/ec_globals.h:7, from ../../include/ec.h:54, from ec_darwin.c:21:

/usr/include/resolv.h:138: error: `NS_MAXDNAME' undeclared here (not in a function) make[2]: * [libec_os_a-ec_darwin.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive] Error 1 Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_net_ettercap-ng/ work/ettercap-NG-0.7.1" && make all" returned error 2Command output: Making all in include make all-am make[2]: Nothing to be done for `all-am'. Making all in include make all-am make[2]: Nothing to be done for `all-am'. Making all in src Making all in os if gcc -DHAVE_CONFIG_H -I. -I. -I../../include -O2 -funroll-loops -fomit-frame-pointer -Wall -I/ opt/local/include -I/opt/local/include -I/opt/local/include -I/opt/local/include -g -O2 -MT libec_os_a-ec_darwin.o -MD -MP -MF ".deps/libec_os_a-ec_darwin.Tpo" -c -o libec_os_a-ec_darwin.o test -f 'ec_darwin.c' || echo './'ec_darwin.c; \ then mv -f ".deps/libec_os_a-ec_darwin.Tpo" ".deps/libec_os_a-ec_darwin.Po"; else rm -f ".deps/ libec_os_a-ec_darwin.Tpo"; exit 1; fi In file included from ../../include/ec_resolv.h:12,

from ../../include/ec_profiles.h:8, from ../../include/ec_packet.h:8, from ../../include/ec_sniff.h:7, from ../../include/ec_globals.h:7, from ../../include/ec.h:54, from ec_darwin.c:21:

/usr/include/arpa/nameser_compat.h:99: error: conflicting types for `HEADER' /usr/include/arpa/nameser.h:304: error: previous declaration of `HEADER' In file included from ../../include/ec_resolv.h:14,

from ../../include/ec_profiles.h:8, from ../../include/ec_packet.h:8, from ../../include/ec_sniff.h:7, from ../../include/ec_globals.h:7, from ../../include/ec.h:54, from ec_darwin.c:21:

/usr/include/resolv.h:138: error: `NS_MAXDNAME' undeclared here (not in a function) make[2]: * [libec_os_a-ec_darwin.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive] Error 1

Warning: the following items did not execute (for ettercap-ng): com.apple.build

comment:4 Changed 15 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to ultrix@…
Status: assignednew

Changed 15 years ago by ultrix@…

Attachment: Portfile.diff added

Portfile patch

Changed 15 years ago by ultrix@…

Attachment: patch-src-Makefile.in added

Updated Makefile.in patch

Changed 15 years ago by ultrix@…

Attachment: patch-configure added

Configure patch

comment:5 Changed 15 years ago by ultrix@…

Resolution: fixed
Status: newclosed

I updated the portfile to use the new ettercap 0.7.3. Also fixed the unresolved external and got rid of the -L/opt/local/src lib path on the libnet linker line.

comment:6 Changed 15 years ago by ultrix@…

Cc: gunnmjk@… added

comment:7 Changed 15 years ago by ultrix@…

* Bug 3271 has been marked as a duplicate of this bug. *

comment:8 Changed 15 years ago by psychotron@…

(In reply to comment #5)

I updated the portfile to use the new ettercap 0.7.3. Also fixed the unresolved external and got rid of

the

-L/opt/local/src lib path on the libnet linker line.

http://darwinports.opendarwin.org/darwinports/dports/net/ettercap-ng/Portfile Here i see 0.7.1... and also by run port info ettercap-ng.

I must manually patch these files?

comment:9 Changed 15 years ago by unlucio@…

All those fix and patches are missing in the port tree =((( so this still doesn't work =((

the port version is still 0.7.1

patching the Portfile doesn't help anyway

--> this is what appens <-- DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/ettercap-ng DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/ettercap-ng DEBUG: Requested variant powerpc is not provided by port ettercap-ng. DEBUG: Requested variant darwin is not provided by port ettercap-ng. DEBUG: Requested variant macosx is not provided by port ettercap-ng. Portfile changed since last build; discarding previous state. DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/openssl DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/openssl DEBUG: Searching for dependency: openssl DEBUG: Found Dependency: receipt exists for openssl DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libpcap DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libpcap DEBUG: Searching for dependency: libpcap DEBUG: Found Dependency: receipt exists for libpcap DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libnet11 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libnet11 DEBUG: Searching for dependency: libnet11 DEBUG: Found Dependency: receipt exists for libnet11 DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/pcre DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/pcre DEBUG: Searching for dependency: pcre DEBUG: Found Dependency: receipt exists for pcre DEBUG: Executing com.apple.main (ettercap-ng) DEBUG: No TGZ archive: /opt/local/var/db/dports/packages/darwin/powerpc/ettercap- ng-0.7.3_0.powerpc.tgz DEBUG: Skipping unarchive (ettercap-ng) since no archive found DEBUG: Skipping completed com.apple.unarchive (ettercap-ng) ---> Fetching ettercap-ng DEBUG: Executing com.apple.fetch (ettercap-ng) ---> patch-configure doesn't seem to exist in /opt/local/var/db/dports/distfiles/ettercap-ng ---> Attempting to fetch patch-configure from http://distfiles-od.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-od.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0

curl: (22) The requested URL returned error: 404 ---> Attempting to fetch patch-configure from http://distfiles-msn.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-msn.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

curl: (22) The requested URL returned error: 404 ---> Attempting to fetch patch-configure from http://distfiles-bay13.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-bay13.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

curl: (22) The requested URL returned error: 404 Error: Target com.apple.fetch returned: fetch failed Warning: the following items did not execute (for ettercap-ng): com.apple.activate com.apple.fetch com.apple.extract com.apple.checksum com.apple.patch com.apple.configure com.apple.build com.apple.destroot com.apple.archive com.apple.install

--> end <--

please help!!! =)))

comment:10 Changed 15 years ago by phlyingpenguin@…

Is this bug supposed to be fixed in the ports tree? I've been toying with getting ettercap to work on OS X since yesterday and finally came across this. The portfile that comes from running port install ettercap-ng still suffers from the problem in my experience.

comment:11 Changed 15 years ago by blb@…

Resolution: fixed
Status: closedreopened

Seth, I take it the patches listed in comments 2, 3, and 4 need to be applied?

comment:12 Changed 15 years ago by blb@…

Cc: unlucio@… added

* Bug 3954 has been marked as a duplicate of this bug. *

comment:13 Changed 15 years ago by ultrix@…

yes, the portfile.patch patches the existing portfile. the other two patches go in the files subdir so darwinports can use them to patch ettercap-ng. Also, I don't have commit access, so if someone who does can get these into cvs, that would be great.

comment:14 Changed 15 years ago by blb@…

Resolution: fixed
Status: reopenedclosed

Now that the CVS server is back, your changes have been committed.

Note: See TracTickets for help on using tickets.