New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #30322 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

ImageMagick won't compile/install on Lion

Reported by: kevinslonka@… Owned by: ryandesign@…
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: lion Cc: quest@…, tristan.klocke@…, Deil.Christoph@…
Port: ImageMagick

Description (last modified by ryandesign@…) (diff)

I had MacPorts and ImageMagick installed and working fine on Snow Leopard. Upgraded to Lion, followed the migration instructions, and got mostly everything reinstalled except ImageMagick.

Error: Target org.macports.destroot returned: shell command failed (see log for details)

It seems to die when installing the Miff coder...

Snippet from log:

:info:destroot libtool: install: /usr/bin/install -c coders/.libs/miff.lai /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_ImageMagick/ImageMagick/work/destroot/opt/local/lib/ImageMagick-6.7.1/modules-Q16/coders/miff.la
:info:destroot install: coders/.libs/miff.lai: No such file or directory
:info:destroot make[2]: *** [install-codersLTLIBRARIES] Error 71

Full log attahed.

Attachments

main.log (96.9 KB) - added by kevinslonka@… 3 years ago.
ImageMagick install log
libXt.la (1.1 KB) - added by Deil.Christoph@… 3 years ago.
libICE.la (924 bytes) - added by Deil.Christoph@… 3 years ago.

Change History

Changed 3 years ago by kevinslonka@…

ImageMagick install log

comment:1 Changed 3 years ago by jmr@…

  • Keywords lion added; ImageMagick removed
  • Owner changed from macports-tickets@… to ryandesign@…
  • Description modified (diff)

Please remember to cc the maintainer.

comment:2 Changed 3 years ago by ryandesign@…

  • Description modified (diff)

comment:3 Changed 3 years ago by quest@…

  • Cc quest@… added

Cc Me!

comment:4 follow-up: ↓ 5 Changed 3 years ago by jamesfmarshall@…

I had no problem installing ImageMagick and all its dependencies.

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 3 years ago by kevinslonka@…

Replying to jamesfmarshall@…:

I had no problem installing ImageMagick and all its dependencies.

What did you do to get it to install, specifically? How did you upgrade to Lion? I'd like to see if your system is different than mine or if you did a step slightly different than I did.

comment:6 in reply to: ↑ 5 Changed 3 years ago by jamesfmarshall@…

Replying to kevinslonka@…:

What did you do to get it to install, specifically? How did you upgrade to Lion? I'd like to see if your system is different than mine or if you did a step slightly different than I did.

I did nothing special. I did follow the migration instructions - uninstall everything, then reinstall. Standard sudo port install.

comment:7 Changed 3 years ago by tristan.klocke@…

  • Cc tristan.klocke@… added

Cc Me!

comment:8 Changed 3 years ago by Deil.Christoph@…

  • Cc Deil.Christoph@… added

Cc Me!

comment:9 follow-up: ↓ 10 Changed 3 years ago by Deil.Christoph@…

For me the build fails like this (on Lion):

:info:build   CC     utilities/stream.o
:info:build   CCLD   magick/libMagickCore.la
:info:build   CCLD   ltdl/dlopen.la
:info:build   CCLD   ltdl/libltdlc.la
:info:build /usr/bin/nm: no name list
:info:build /usr/bin/ranlib: file: magick/.libs/libMagickCore.a(magick_libMagickCore_la-PreRvIcccm.o) has no symbols
:info:build ranlib: file: magick/.libs/libMagickCore.a(magick_libMagickCore_la-PreRvIcccm.o) has no symbols
:info:build   CCLD   coders/art.la
:info:build   CCLD   coders/aai.la
:info:build   CCLD   coders/avs.la
:info:build   CCLD   coders/bgr.la
:info:build   CCLD   coders/bmp.la
:info:build   CCLD   coders/braille.la
:info:build   CCLD   coders/cals.la
:info:build   CCLD   coders/caption.la
:info:build   CCLD   coders/cin.la
:info:build   CCLD   coders/cip.la
:info:build   CCLD   coders/clip.la
:info:build   CCLD   coders/cmyk.la
:info:build   CCLD   coders/cut.la
:info:build   CCLD   coders/dcm.la
:info:build   CCLD   coders/dds.la
:info:build   CCLD   coders/debug.la
:info:build   CCLD   coders/dib.la
:info:build   CCLD   coders/dng.la
:info:build   CCLD   coders/dot.la
:info:build   CCLD   coders/dpx.la
:info:build   CCLD   coders/fax.la
:info:build   CCLD   coders/fits.la
:info:build   CCLD   coders/gif.la
:info:build   CCLD   coders/gradient.la
:info:build   CCLD   coders/gray.la
:info:build   CCLD   coders/hald.la
:info:build   CCLD   coders/hdr.la
:info:build   CCLD   coders/histogram.la
:info:build   CCLD   coders/hrz.la
:info:build   CCLD   coders/html.la
:info:build   CCLD   coders/icon.la
:info:build libtool: link: `/opt/local/lib/libICE.la' is not a valid libtool archive
:info:build libtool: link: `/opt/local/lib/libXt.la' is not a valid libtool archive
:info:build make[1]: *** [coders/html.la] Error 1

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 3 years ago by ryandesign@…

Replying to Deil.Christoph@…:

:info:build libtool: link: `/opt/local/lib/libICE.la' is not a valid libtool archive
:info:build libtool: link: `/opt/local/lib/libXt.la' is not a valid libtool archive

Why are those files not valid libtool archives? What's in them? (Can you attach them here?)

Changed 3 years ago by Deil.Christoph@…

Changed 3 years ago by Deil.Christoph@…

comment:11 in reply to: ↑ 10 Changed 3 years ago by Deil.Christoph@…

Replying to ryandesign@…:

Replying to Deil.Christoph@…:

:info:build libtool: link: `/opt/local/lib/libICE.la' is not a valid libtool archive
:info:build libtool: link: `/opt/local/lib/libXt.la' is not a valid libtool archive

Why are those files not valid libtool archives? What's in them? (Can you attach them here?)

I have attached them. No idea what happened there, I had never heard of those files. They were last modified on Jul 23, so if they indeed are invalid the problem is not with the ImageMagick port, but with the ports that installed them.

comment:12 Changed 3 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate

Hmm, those files are fine; they're identical to the ones on my system. They're provided by the xorg-libice and xorg-libXt ports, by the way.

So I'll call this a duplicate of the inexplicable #30809.

comment:13 follow-up: ↓ 15 Changed 3 years ago by ryandesign@…

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Actually I'm not sure Christoph's issue is the same as the previous issues in this ticket, so I'll keep the ticket open. Christoph, based on #30809, it seems the issue may be intermittent, so clean and try again, a few times if necessary.

comment:14 in reply to: ↑ description Changed 3 years ago by ryandesign@…

Replying to kevinslonka@…:

It seems to die when installing the Miff coder...

Kevin, your log is incomplete (contains lines saying "Skipping completed") so I'm not sure the error you're seeing is the relevant one. Can you clean and try again, and if it fails again, attach the complete main.log? Thanks.

sudo port clean imagemagick

comment:15 in reply to: ↑ 13 ; follow-up: ↓ 16 Changed 3 years ago by Deil.Christoph@…

Replying to ryandesign@…:

Christoph, based on #30809, it seems the issue may be intermittent, so clean and try again, a few times if necessary.

Worked on the first clean / re-install try:

$ sudo port clean imagemagick
Password:
--->  Cleaning imagemagick
$ sudo port install imagemagick
--->  Computing dependencies for imagemagick
--->  Fetching archive for imagemagick
--->  Attempting to fetch imagemagick-6.7.2-0_0+q16.darwin_11.x86_64.tbz2 from http://packages.macports.org/imagemagick
--->  Fetching imagemagick
--->  Verifying checksum(s) for imagemagick
--->  Extracting imagemagick
--->  Configuring imagemagick
--->  Building imagemagick
--->  Staging imagemagick into destroot
--->  Installing imagemagick @6.7.2-0_0+q16
--->  Activating imagemagick @6.7.2-0_0+q16
--->  Cleaning imagemagick
$

Strange ...

comment:16 in reply to: ↑ 15 Changed 3 years ago by kevinslonka@…

Replying to Deil.Christoph@…:

Yeah, mine worked too the first clean/install despite my trying this about 10 times before I first submitted the bug. I wonder if an update has been done to the port or what.... this is odd.

comment:17 Changed 3 years ago by ryandesign@…

  • Status changed from reopened to closed
  • Resolution set to worksforme

ImageMagick has been updated, most recently in r83195. Glad you got it working.

Note: See TracTickets for help on using tickets.