Opened 9 years ago

Closed 9 years ago

#30374 closed defect (duplicate)

Error updating gmp

Reported by: manuel.deljesuspe@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc:
Port: gmp

Description (last modified by ryandesign (Ryan Schmidt))

I updated to macports 2.0.0. At that very same momento gmp was to be uptaded but it always throws the following error:

--->  Fetching archive for gmp
--->  Fetching gmp
--->  Attempting to fetch gmp-5.0.2.tar.bz2 from http://lil.fr.distfiles.macports.org/gmp
--->  Verifying checksum(s) for gmp
--->  Extracting gmp
--->  Applying patches to gmp
--->  Configuring gmp
--->  Building gmp
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for gmp is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/main.log
Error: Unable to upgrade port: 1

The list of outdated packages is:

gmp                            5.0.2_0 < 5.0.2_1         
octave                         3.2.4_4 < 3.2.4_5         
py27-numpy                     1.6.0_0 < 1.6.1_0         
py27-py2app                    0.6.3_0 < 0.6.3_1         
SuiteSparse                    3.4.0_0 < 3.4.0_1         
szip                           2.1_2 < 2.1_3             
xorg-inputproto                2.0.1_0 < 2.0.2_0         
xorg-libXrandr                 1.3.1_0 < 1.3.2_0         
xorg-util-macros               1.14.0_0 < 1.15.0_0 

The GMP log file (just the end of it) shows the error:

:info:build Assertion failed: (_file->_atomsArrayCount == computedAtomCount && "more atoms allocated than expected"), function parse, file /SourceCache/ld64/ld64-123.2/src/ld/parsers/macho_relocatable_file.cpp, line 1545.
:info:build 0  0x10001286c  __assert_rtn + 76
:info:build 1  0x100043fb8  mach_o::relocatable::Parser<x86_64>::parse(mach_o::relocatable::ParserOptions const&) + 2104
:info:build 2  0x10001ed87  mach_o::relocatable::Parser<x86_64>::parse(unsigned char const*, unsigned long long, char const*, long, unsigned int, mach_o::relocatable::ParserOptions const&) + 295
:info:build 3  0x1000183ef  mach_o::relocatable::parse(unsigned char const*, unsigned long long, char const*, long, unsigned int, mach_o::relocatable::ParserOptions const&) + 159
:info:build 4  0x1000727a1  ld::tool::InputFiles::makeFile(Options::FileInfo const&) + 497
:info:build 5  0x100073f79  ld::tool::InputFiles::InputFiles(Options&, char const**) + 697
:info:build 6  0x100012a97  main + 311
:info:build 7  0x100000e14  start + 52
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[2]: *** [libgmp.la] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/work/gmp-5.0.2'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/work/gmp-5.0.2'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/work/gmp-5.0.2'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/work/gmp-5.0.2" && /usr/bin/make -j2 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for gmp): org.macports.install org.macports.build org.macports.destroot
:notice:build Log for gmp is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_gmp/gmp/main.log

Change History (3)

comment:1 Changed 9 years ago by manuel.deljesuspe@…

Cc: manuel.deljesuspe@… added

Cc Me!

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: manuel.deljesuspe@… removed
Description: modified (diff)
Keywords: gmp update removed
Owner: changed from macports-tickets@… to mcalhoun@…
Type: updatedefect

Use WikiFormatting please. As reporter, you do not need to be Cc'd, but please do Cc the port's maintainer.

comment:3 Changed 9 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #30294; please search before filing new tickets.

Note: See TracTickets for help on using tickets.