Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#30391 closed defect (fixed)

gnome-python-desktop build failure

Reported by: mf2k (Frank Schima) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc:
Port: gnome-python-desktop

Description

  • Mac OS X 10.6.8
  • Xcode 3.2.6

I'm seeing the following build error:

:info:build /bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2 -D_REENTRANT -I/opt/local/include/metacity-1 -I/opt/local/include/gtk-2.0 -I/opt/local/lib/gtk-2.0/include -I/opt/local/include/atk-1.0 -I/opt/local/include/cairo -I/opt/local/include/gdk-pixbuf-2.0 -I/opt/local/include/pango-1.0 -I/opt/local/include/gio-unix-2.0/ -I/opt/local/include -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng14   -pipe -O2 -arch x86_64 -Wall -std=c9x -fno-strict-aliasing -module -avoid-version -export-symbols-regex initmetacity -L/opt/local/lib -arch x86_64 -o metacity.la -rpath /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/gtk-2.0 metacity_la-metacitymodule.lo metacity_la-metacity.lo -L/opt/local/lib -lmetacity-private -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpng14 -lpango-1.0 -lm -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lintl   
:info:build /opt/local/bin/grep: /opt/local/lib/libxcb-aux.la: No such file or directory
:info:build /opt/local/bin/gsed: can't read /opt/local/lib/libxcb-aux.la: No such file or directory
:info:build libtool: link: `/opt/local/lib/libxcb-aux.la' is not a valid libtool archive
:info:build make[2]: *** [metacity.la] Error 1

Attachments (1)

main.log (135.5 KB) - added by mf2k (Frank Schima) 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:1 Changed 9 years ago by jmroot (Joshua Root)

libxcb-aux is gone from newer xorg-xcb-util versions. Which of your .la files reference libxcb-aux.la? The providing ports may need to be rebuilt/rev-bumped.

comment:2 Changed 8 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Based on the context, I am guessing that the problem came from metacity which was revbumped for this sort of problem along with other ports depending on xorg-xcb-util in r94194.

Assuming fixed.

comment:3 Changed 8 years ago by mf2k (Frank Schima)

Sorry, totally forgot about this one. Yes, it builds for me on 10.8 now.

Note: See TracTickets for help on using tickets.