Opened 10 years ago

Closed 10 years ago

#30394 closed defect (duplicate)

libplist build error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."

Reported by: mf2k (Frank Schima) Owned by: rmstonecipher@…
Priority: Normal Milestone:
Component: ports Version: 2.0.99
Keywords: Cc:
Port: libplist

Description

  • Mac OS X 10.6.8
  • Xcode 3.2.6

I see the following error trying to build libplist.

:info:build cd /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig && /usr/bin/g++-4.2   -D_plist_EXPORTS -pipe -O2 -arch x86_64  -O3 -DNDEBUG -arch x86_64 -isysroot / -mmacosx-version-min=10.6 -fPIC -I/opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/include -I/Library/Frameworks/Python.framework/Headers   -o CMakeFiles/_plist.dir/plistPYTHON_wrap.cxx.o -c /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx
:info:build In file included from /Library/Frameworks/Python.framework/Headers/Python.h:57,
:info:build                  from /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:149:
:info:build /Library/Frameworks/Python.framework/Headers/pyport.h:761:2: error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx: In function ‘PyObject* _wrap_new_Date__SWIG_4(PyObject*, PyObject*)’:
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9574: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9574: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx: In function ‘PyObject* _wrap_new_Date(PyObject*, PyObject*)’:
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9635: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9635: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx: In function ‘PyObject* _wrap_Date_set_value(PyObject*, PyObject*)’:
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9727: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9727: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx: In function ‘PyObject* _wrap_Date_get_value(PyObject*, PyObject*)’:
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9773: warning: deprecated conversion from string constant to ‘char*’
:info:build /opt/local/var/macports/build/_opt_mports_trunk_dports_textproc_libplist/libplist/work/libplist-1.4/swig/plistPYTHON_wrap.cxx:9773: warning: deprecated conversion from string constant to ‘char*’
:info:build make[2]: *** [swig/CMakeFiles/_plist.dir/plistPYTHON_wrap.cxx.o] Error 1

Attachments (1)

main.log (65.3 KB) - added by mf2k (Frank Schima) 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by mf2k (Frank Schima)

Attachment: main.log added

comment:1 Changed 10 years ago by rmstonecipher@…

Frank,
It's going to take me a few days to set up a 10.6 VM now that I'm on 10.7.
If you come to a solution before then, feel free to post and/or commit it.

Cheers,
Ryan Stonecipher

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: libplist build errorlibplist build error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."

libplist 1.8 builds fine for me on OS X 10.6.8 with Xcode 3.2.6 so it's something unique to Frank's system.

The error seems to be:

:info:build /Library/Frameworks/Python.framework/Headers/pyport.h:761:2: error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."

Where did /Library/Frameworks/Python.framework come from? It should be removed. Frameworks not provided by MacPorts installed in /Library/Frameworks frequently cause problems. Duplicate of #27094.

Note: See TracTickets for help on using tickets.