Opened 10 years ago

Closed 10 years ago

#30412 closed defect (fixed)

bacula @5.0.3 is broken with macports 2.0

Reported by: linksrum@… Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc:
Port: bacula

Description

Staging bacula into destroot breaks with

Error: Target org.macports.destroot returned: error renaming "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_bacula/bacula/work/destroot/opt/local/etc/bacula/bacula-fd.conf": no such file or directory
Error: Status 1 encountered during processing.

The same problem applies to bconsole.conf. I managed to get it installed after creating these files manually, but found bconsole binary not to be installed.

(Bacula 5.0.3 with Macports 1.9.2 installs properly. Checked on another host.)

Attachments (1)

main.log (31.3 KB) - added by linksrum@… 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to macsforever2000@…
Port: bacula added

comment:2 Changed 10 years ago by mf2k (Frank Schima)

I cannot reproduce this. Please attach the build log mentioned in the output.

Also, what version of Mac OS X and Xcode are you running?

Changed 10 years ago by linksrum@…

Attachment: main.log added

comment:3 Changed 10 years ago by linksrum@…

It's on MacOS X 10.6.7 with Xcode 3.2.3

comment:4 Changed 10 years ago by mf2k (Frank Schima)

Do you have ccache installed?

port installed ccache

If so, try uninstalling it, clean bacula and try again.

comment:5 Changed 10 years ago by mf2k (Frank Schima)

Also, I need a clean build log, meaning that you should reattach that log after the clean.

comment:6 Changed 10 years ago by linksrum@…

Problem, solved. :-) Deactivating ccache was enough.

sudo port deactivate ccache

Thanks!

comment:7 Changed 10 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: newclosed

Good. I'm not sure how to prevent that.

comment:8 Changed 10 years ago by jmroot (Joshua Root)

You can put configure.ccache no in the portfile.

comment:9 Changed 10 years ago by mf2k (Frank Schima)

Resolution: worksforme
Status: closedreopened

comment:10 Changed 10 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: reopenedclosed

r81489. Thanks jmr!

Note: See TracTickets for help on using tickets.