Opened 8 years ago

Closed 8 years ago

#30448 closed defect (fixed)

commons-fileupload: Directory /var/root/.maven/repository creation was not successful for an unknown reason

Reported by: nic@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc: magnus.karlsson@…, gavinb@…, ryandesign (Ryan Schmidt)
Port: commons-fileupload

Description

I've done:

sudo port clean all
sudo port install tomcat5

I get:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_java_commons-fileupload/commons-fileupload/work/commons-fileupload-1.2.1-src/build.xml:54: Directory /var/root/.maven/repository creation was not successful for an unknown reason
:info:build
:info:build Total time: 0 seconds
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_java_commons-fileupload/commons-fileupload/work/commons-fileupload-1.2.1-src" && ant dist -Dfinal.name=commons-fileupload -Dnoget=true " returned error 1
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for commons-fileupload): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:error:build Failed to install commons-fileupload
:notice:build Log for commons-fileupload is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_java_commons-fileupload/commons-fileupload/main.log

Attachments (1)

main.log (7.3 KB) - added by nic@… 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by nic@…

Attachment: main.log added

comment:1 Changed 8 years ago by nic@…

Cc: nic@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: nic@… removed

MacPorts 2.0.0 drops privileges to an unprivileged user who does not have permission to create that directory. The port should not be attempting to create that directory and should be fixed to not do so.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Keywords: lion removed
Summary: commons-fileupload fails to install on Lioncommons-fileupload: Directory /var/root/.maven/repository creation was not successful for an unknown reason

comment:4 Changed 8 years ago by nic@…

Is there a temporary workaround since this is blocking an install of tomcat5

comment:5 Changed 8 years ago by jmroot (Joshua Root)

Appending build.asroot=yes to the command line would probably work around.

comment:6 Changed 8 years ago by nic@…

Confirmed - "sudo port install tomcat5 build.asroot=yes" got commons-fileupload installed :)

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: magnus.karlsson@… added

Has duplicate #30784.

comment:8 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: gavinb@… added

Has duplicate #31345.

comment:9 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.