Opened 8 years ago

Closed 8 years ago

#30484 closed defect (fixed)

kdebase4-runtime: kdebase4-runtime-4.6.5: no such file or directory

Reported by: derek.enos@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc:
Port: kdebase4-runtime

Description (last modified by ryandesign (Ryan Schmidt))

OS X 10.6.8, MacPorts v2.0.0

kdebase4-runtime not found when attempting to install kdenlive @0.8 (log below).

Changeset 81431 replaces "kdebase4-runtime" with "kde4-runtime". Perhaps this is relevant?

version:1
:debug:main Executing org.macports.main (kdebase4-runtime)
:debug:main Skipping completed org.macports.archivefetch (kdebase4-runtime)
:debug:main Skipping completed org.macports.fetch (kdebase4-runtime)
:debug:main Skipping completed org.macports.checksum (kdebase4-runtime)
:debug:extract extract phase started at Sat Jul 30 22:45:35 EDT 2011
:notice:extract --->  Extracting kdebase4-runtime
:debug:extract Executing proc-pre-org.macports.extract-extract-0
:debug:extract Executing org.macports.extract (kdebase4-runtime)
:debug:extract Executing proc-post-org.macports.extract-extract-0
:debug:extract Executing proc-post-org.macports.extract-extract-1
:error:extract Target org.macports.extract returned: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/kdebase4-runtime/work/kdebase4-runtime-4.6.5: no such file or directory
:debug:extract Backtrace: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/kdebase4-runtime/work/kdebase4-runtime-4.6.5: no such file or directory
    while executing
"$post $targetname"
:info:extract Warning: the following items did not execute (for kdebase4-runtime): org.macports.activate org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:extract Failed to install kdebase4-runtime
:notice:extract Log for kdebase4-runtime is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdebase4-runtime/kdebase4-runtime/main.log

Change History (10)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Port: kdebase4-runtime added; kdenlive removed
Resolution: duplicate
Status: newclosed
Summary: kdenlive @0.8 "kdebase4-runtime-4.6.5" not foundkdebase4-runtime: kdebase4-runtime-4.6.5: no such file or directory

selfupdate, clean and try again.

sudo port selfupdate
sudo port clean kdebase4-runtime

Duplicate of #29223.

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:3 Changed 8 years ago by macports@…

This is due to a number of ports still listing kdebase4-runtime as a dependency rather than kde4-runtime.

Indeed, kdenlive is one such port, but I had already hit this somewhat strange error even before that as some of the basic kde packages (kdepim4, kdenetwork4, etc) had the wrong name for the dependency. A search/replace in the ports dir followed by portindex took care of it for me.

This is all fallout from the rename as it seems the replaced-by directive only affects upgrades and not dependency handling. Again, lack of testing and committing piecewise makes more pain for the users.

comment:4 Changed 8 years ago by macports@…

Resolution: duplicate
Status: closedreopened

As of this moment in time (full rsync of ports to a fresh temp dir), the following ports still list kdebase4-runtime as a dependency:

kde/amarok
kde/amarok-devel
kde/kdegames4
kde/kdegraphics4
kde/kdenetwork4
kde/kdepim4-runtime
kde/kdesvn
kde/krusader
kde/ktorrent
kde/ktorrent4
multimedia/kdenlive
tex/kile-devel

It was bad enough that change was not made atomically. It is worse that numerous directly related ports are still left untouched and now effectively broken. Making this list was one-liner. Fixing it would only take two more. I'd do it, but I can't commit, so yet again I have a locally fixed tree which will be smashed when I do the next sync or selfupdate if these ports are not fixed in svn before then.

comment:5 Changed 8 years ago by nicos_pavlov@…

kdegraphics4 does not exist anymore anyway in KDE 4.7. I propose new ports that are replacing the port kdegraphics4 in ticket #30493.
I will also upload an update for kile-devel in ticket #30214, as it had to be updated anyway.

comment:6 in reply to:  5 Changed 8 years ago by macports@…

Replying to nicos_pavlov@…:

kdegraphics4 does not exist anymore anyway in KDE 4.7. I propose new ports that are replacing the port kdegraphics4 in ticket #30493.
I will also upload an update for kile-devel in ticket #30214, as it had to be updated anyway.

Thank you for your efforts Nicos.

To be clear, I was not asking that all these ports be updated to their current versions, but rather that at a minimum they list dependencies which can be satisfied. It is of course an opportune time to make other changes to those ports, like updating to current version or replacing them in the case a package no longer exists as previously known, but that is icing compared to simply being able to resolve the deps.

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to snc@…
Status: reopenednew

Jeremy, you made kdebase4-runtime replaced_by kde4-runtime in r81431; you need to modify all ports still depending on kdebase4-runtime to now depend on kde4-runtime. No need to ask maintainers for approval since things are broken without this change.

comment:8 Changed 8 years ago by nerdling (Jeremy L)

Status: newassigned

amarok-devel amarok kdesvn krusader ktorrent ktorrent4 in r81525.

comment:9 Changed 8 years ago by nerdling (Jeremy L)

kdenlive in r81526.

kile-devel in r81527.

comment:10 Changed 8 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.