Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#30529 closed defect (duplicate)

ntop build error

Reported by: pengyu.ut@… Owned by: markd@…
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: Cc:
Port: ntop

Description (last modified by ryandesign (Ryan Schmidt))

I get the following error when I try to install ntop. Could anybody let me know how to fix the problem?

~$ sudo port install ntop 
Password:
--->  Computing dependencies for ntop
--->  Dependencies to be installed: libevent libgeoip libpcap rrdtool tcl wget
--->  Fetching archive for libevent
--->  Fetching libevent
--->  Attempting to fetch libevent-2.0.10-stable.tar.gz from http://monkey.org/~provos/
--->  Verifying checksum(s) for libevent
--->  Extracting libevent
--->  Configuring libevent
--->  Building libevent
--->  Staging libevent into destroot
--->  Installing libevent @2.0.10_0
--->  Activating libevent @2.0.10_0
--->  Cleaning libevent
--->  Fetching archive for libgeoip
--->  Fetching libgeoip
--->  Attempting to fetch GeoIP-1.4.7.tar.gz from http://distfiles.macports.org/libgeoip
--->  Verifying checksum(s) for libgeoip
--->  Extracting libgeoip
--->  Configuring libgeoip
--->  Building libgeoip
--->  Staging libgeoip into destroot
--->  Installing libgeoip @1.4.7_0
--->  Activating libgeoip @1.4.7_0
--->  Cleaning libgeoip
--->  Fetching archive for libpcap
--->  Fetching libpcap
--->  Attempting to fetch libpcap-1.1.1.tar.gz from http://www.tcpdump.org/release/
--->  Verifying checksum(s) for libpcap
--->  Extracting libpcap
--->  Applying patches to libpcap
--->  Configuring libpcap
--->  Building libpcap
--->  Staging libpcap into destroot
--->  Installing libpcap @1.1.1_0
--->  Activating libpcap @1.1.1_0
--->  Cleaning libpcap
--->  Fetching archive for tcl
--->  Fetching tcl
--->  Verifying checksum(s) for tcl
--->  Extracting tcl
--->  Configuring tcl
--->  Building tcl
--->  Staging tcl into destroot
--->  Installing tcl @8.5.9_0
--->  Activating tcl @8.5.9_0
--->  Cleaning tcl
--->  Fetching archive for rrdtool
--->  Fetching rrdtool
--->  Attempting to fetch rrdtool-1.4.4.tar.gz from http://distfiles.macports.org/rrdtool
--->  Verifying checksum(s) for rrdtool
--->  Extracting rrdtool
--->  Applying patches to rrdtool
--->  Configuring rrdtool
--->  Building rrdtool
--->  Staging rrdtool into destroot
--->  Installing rrdtool @1.4.4_1

See /opt/local/share/doc/rrdtool for example code

--->  Activating rrdtool @1.4.4_1
--->  Cleaning rrdtool
--->  Fetching archive for wget
--->  Fetching wget
--->  Verifying checksum(s) for wget
--->  Extracting wget
--->  Applying patches to wget
--->  Configuring wget
--->  Building wget
--->  Staging wget into destroot
--->  Installing wget @1.12_3+ssl
--->  Activating wget @1.12_3+ssl
To customize wget, you can copy wgetrc.sample to wgetrc
in /opt/local/etc and then make changes.
--->  Cleaning wget
--->  Fetching archive for ntop
--->  Fetching ntop
--->  Attempting to fetch ntop-3.3.10.tar.gz from http://softlayer.dl.sourceforge.net/ntop
--->  Verifying checksum(s) for ntop
--->  Extracting ntop
--->  Applying patches to ntop
--->  Configuring ntop
--->  Building ntop
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for ntop is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_ntop/ntop/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (126.9 KB) - added by pengyu.ut@… 9 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_ntop/ntop/main.log

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by pengyu.ut@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_ntop/ntop/main.log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to markd@…
Port: ntop added
Priority: HighNormal

Please use WikiFormatting and preview before submitting; fill in the Port field; Cc the port's maintainer; don't set Priority to High; and most importantly, search for existing tickets before filing a new one. This is a duplicate of #27472.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

comment:3 in reply to:  2 Changed 9 years ago by pengyu.ut@…

Resolution: duplicate
Status: closedreopened

Replying to ryandesign@…:

I don't see a solution on #27472

What is the solution?

comment:4 Changed 9 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: reopenedclosed

There is none yet. This is still a duplicate, so please don't re-open this ticket.

comment:5 Changed 9 years ago by pengyu.ut@…

Does everybody who want to install ntop see the same problem? Or it is just some people see the problem, but not others?

Note: See TracTickets for help on using tickets.