Opened 8 years ago

Closed 8 years ago

#30631 closed defect (worksforme)

kdegames4 tries to use non-standard OpenAL framework

Reported by: soehn@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: sharky@…, michaelld (Michael Dickens), mkae (Marko Käning)
Port: kdegames4

Description (last modified by nerdling (Jeremy L))

kdegames4 tries to use OpenAL in /Library. I have attached the log-file.

Attachments (2)

main.log (2.0 MB) - added by soehn@… 8 years ago.
main.2.log (2.1 MB) - added by soehn@… 8 years ago.

Change History (12)

Changed 8 years ago by soehn@…

Attachment: main.log added

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Cc: sharky@… added
Owner: changed from macports-tickets@… to snc@…

Please remember to cc the maintainers.

comment:2 Changed 8 years ago by nerdling (Jeremy L)

Cc: michaelld@… mk@… added

Is /Library/Frameworks/OpenAL standard to the Lion install? If not, we should forcibly define this in the KDE portgroup.

:info:build /Library/Frameworks/OpenAL.framework/Headers/al.h:87: error: ‘<anonymous>’ has incomplete type
:info:build /Library/Frameworks/OpenAL.framework/Headers/al.h:87: error: invalid use of ‘ALvoid’
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdegames4/kdegames4/work/kdegames-4.7.0/granatier/src/TagaroAudio/openalruntime_p.h:26,

comment:3 Changed 8 years ago by nerdling (Jeremy L)

Status: newassigned

I've verified that /Library/Frameworks is empty on a clean Lion install. We need to force OpenAL in the KDE PortGroup.

comment:4 Changed 8 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed

OpenAL forced in r82308. Please update, clean, and try again.

Changed 8 years ago by soehn@…

Attachment: main.2.log added

comment:5 in reply to:  4 Changed 8 years ago by soehn@…

Resolution: fixed
Status: closedreopened

Replying to snc@…:

OpenAL forced in r82308. Please update, clean, and try again.

I did try it, I attached the result.

comment:6 Changed 8 years ago by nerdling (Jeremy L)

Description: modified (diff)
Keywords: lion removed
Summary: kdegames4 does not build on Lionkdegames4 tries to use non-standard OpenAL framework

Lovely. LD still thinks it should grab that non-standard OpenAL.

comment:7 Changed 8 years ago by michaelld (Michael Dickens)

After checking the generated CMakeCache.txt file from kdegames4, SNC's changes to the KDE 1.1 PortGroup look good to me. Can the OP do:

sudo port clean kdegames4
sudo port selfupdate
sudo port install kdegames4

and see if that works? Sometimes it takes a bit for changes to become public & your comment is just 1 hour after the change was made.

comment:8 Changed 8 years ago by nerdling (Jeremy L)

Also could you let us know what you installed on your system that put an OpenAL framework in your /Library? We can't reproduce without knowing which software to put there.

comment:9 in reply to:  8 Changed 8 years ago by soehn@…

Replying to snc@…:

Also could you let us know what you installed on your system that put an OpenAL framework in your /Library? We can't reproduce without knowing which software to put there.

That was just the key. I started investigating and noticed there are two versions installed. One very old one (1.0.1d) in /Library/frameworks and a newer one in /system/Library/frameworks (1.5). I decided to move the older version to a safe place. After that kdegames4 did build and runs fine. I will see if any app will miss the old framework... Thank you for your help.

comment:10 Changed 8 years ago by nerdling (Jeremy L)

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.