Opened 10 years ago

Closed 10 years ago

#30655 closed defect (duplicate)

geos @3.3.0: Undefined symbols __ZNSt8auto_ptrIN4geos4geom8EnvelopeEEcvSt12auto_ptr_refIT_EIS2_EEv

Reported by: nlebedev@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: lion Cc: opendarwin@…
Port: geos

Description (last modified by ryandesign (Ryan Schmidt))

Building geos on os x lion with

sudo port install geos +universal 

or

sudo port install geos

fails with error:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for geos is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_geos/geos/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Logfile attached

Attachments (1)

main.log (453.5 KB) - added by nlebedev@… 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by nlebedev@…

Attachment: main.log added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: opendarwin@… added
Description: modified (diff)
Keywords: lion added; geos removed
Resolution: duplicate
Status: newclosed
Summary: geos @3.3.0 Build errorgeos @3.3.0: Undefined symbols __ZNSt8auto_ptrIN4geos4geom8EnvelopeEEcvSt12auto_ptr_refIT_EIS2_EEv

Log says:

:info:build Undefined symbols for architecture x86_64:
:info:build   "__ZNSt8auto_ptrIN4geos4geom8EnvelopeEEcvSt12auto_ptr_refIT_EIS2_EEv", referenced from:
:info:build       virtual thunk to geos::geom::GeometryCollection::computeEnvelopeInternal() constin GeometryCollection.o
:info:build   "std::auto_ptr<geos::geom::Envelope>::auto_ptr(std::auto_ptr_ref<geos::geom::Envelope>)", referenced from:
:info:build       virtual thunk to geos::geom::GeometryCollection::computeEnvelopeInternal() constin GeometryCollection.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build collect2: ld returned 1 exit status

Duplicate of #30309.

comment:2 Changed 10 years ago by nlebedev@…

Resolution: duplicate
Status: closedreopened

Status changed to closed. I've done port -v selfupdate, cleaned geos, but I still have the same error during build.

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: reopenedclosed

Please do not re-open. That does not change that this is a duplicate ticket.

Note: See TracTickets for help on using tickets.