New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #3072 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

BUG: xmms doesn't build under MacOS 10.4

Reported by: gabriele.svelto@… Owned by: shadow@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: firepoet78@…, tscollins2002@…
Port:

Description

xmms installation fails with the following error:

---> Fetching xmms ---> Verifying checksum(s) for xmms ---> Extracting xmms ---> Applying patches to xmms ---> Configuring xmms ---> Building xmms with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_audio_xmms/work/xmms-1.2.8" && make all" returned error 2 Command output: creating libecho.la (cd .libs && rm -f libecho.la && ln -s ../libecho.la libecho.la) Making all in stereo_plugin /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../xmms -I/opt/local/include/gtk-1.2 -I/opt/local/include/glib-1.2 -I/opt/local/lib/glib/include -D_REENTRANT -I/usr/X11R6/include -I../../intl -I../.. -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -c stereo.c gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../xmms -I/opt/local/include/gtk-1.2 -I/opt/local/include/glib-1.2 -I/opt/local/lib/glib/include -D_REENTRANT -I/usr/X11R6/include -I../../intl -I../.. -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -c stereo.c -fno-common -DPIC -o stereo.lo /bin/sh ../../libtool --mode=link gcc -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -o libstereo.la -rpath /opt/local/lib/xmms/Effect -module -avoid-version -export-symbols-regex "get_.plugin_info" stereo.lo -L/opt/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lgthread -lglib -lpthread -lintl -lXext -lX11 -lm mkdir .libs rm -fr .libs/libstereo.la .libs/libstereo.* .libs/libstereo.* (cd . && ln -s stereo.lo stereo.o) generating symbol list for `libstereo.la' /usr/bin/nm -p stereo.lo | sed -n -e 's/.*[ ]\([BCDEGRST][BCDEGRST]*\)[ ][ ]*\(_\)\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2\3 \3/p' | sed 's/.* ' | sort | uniq > .libs/libstereo.exp egrep -e "get_.plugin_info" ".libs/libstereo.exp" > ".libs/libstereo.expT" mv -f ".libs/libstereo.expT" ".libs/libstereo.exp" gcc -bundle -flat_namespace -undefined suppress -o .libs/libstereo.so stereo.lo

-L/opt/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lgthread -lglib

-lpthread -lintl -lXext -lX11 -lm -lc /usr/bin/ld: warning -prebind has no effect with -bundle creating libstereo.la (cd .libs && rm -f libstereo.la && ln -s ../libstereo.la libstereo.la) make[3]: Nothing to be done for `all-am'. Making all in General Making all in ir /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../xmms -I/opt/local/include/gtk-1.2 -I/opt/local/include/glib-1.2 -I/opt/local/lib/glib/include -D_REENTRANT -I/usr/X11R6/include -I../../intl -I../.. -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -c ir.c gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../xmms -I/opt/local/include/gtk-1.2 -I/opt/local/include/glib-1.2 -I/opt/local/lib/glib/include -D_REENTRANT -I/usr/X11R6/include -I../../intl -I../.. -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -c ir.c -fno-common -DPIC -o ir.lo ir.c:19: error: static declaration of 'keepGoing' follows non-static declaration ir.h:53: error: previous declaration of 'keepGoing' was here ir.c:22: error: static declaration of 'irapp_thread' follows non-static declaration ir.h:52: error: previous declaration of 'irapp_thread' was here make[3]: * [ir.lo] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive-am] Error 2

Change History

comment:1 Changed 9 years ago by jmpp@…

  • Owner changed from darwinports-bugs@… to shadow@…

comment:2 Changed 9 years ago by snu@…

  • Summary changed from xmms doesn't build under MacOS 10.4 to BUG: xmms doesn't build under MacOS 10.4

comment:3 Changed 9 years ago by pguyot@…

This actually is a gcc-4 incompatibility. The extern global variables should not be declared static.

However, this port should be updated to 1.2.10.

comment:4 Changed 9 years ago by pguyot@…

  • Cc firepoet78@… added

comment:5 Changed 9 years ago by pguyot@…

* Bug 3229 has been marked as a duplicate of this bug. *

comment:6 Changed 9 years ago by tscollins2002@…

  • Cc tscollins2002@… added

comment:7 Changed 9 years ago by pguyot@…

  • Status changed from new to closed
  • Resolution set to fixed

Committing and resetting the maintainers.

Note: See TracTickets for help on using tickets.