Opened 10 years ago

Closed 9 years ago

#30744 closed defect (duplicate)

apache2: unable to infer tagged configuration

Reported by: oskari.kokko@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: hoyomi@…, jendave@…, jeffszuhay (Jeff Szuhay), conradwt (Conrad Taylor)
Port: apache2

Description (last modified by jmroot (Joshua Root))

OSX 10.6.8 2.2 Intel Core i7 MacBook Pro MacPorts 2.0.1

============================ ============================

$ sudo port install apache2
--->  Computing dependencies for apache2
--->  Fetching archive for apache2
--->  Attempting to fetch apache2-2.2.19_0+preforkmpm.darwin_10.x86_64.tbz2 from http://packages.macports.org/apache2
--->  Fetching apache2
--->  Attempting to fetch httpd-2.2.19.tar.bz2 from http://apache.mirroring.de/httpd
--->  Attempting to fetch httpd-2.2.19.tar.bz2 from http://lil.fr.distfiles.macports.org/apache2
--->  Verifying checksum(s) for apache2
--->  Extracting apache2
--->  Applying patches to apache2
--->  Configuring apache2
--->  Building apache2
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for apache2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/main.log
Error: Status 1 encountered during processing.

============================ ============================

in main.log:

:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19'
:info:build Making all in srclib
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/srclib'
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/srclib'
:info:build Making all in os
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os'
:info:build Making all in unix
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os/unix'
:info:build make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os/unix'
:info:build /opt/local/share/apr-1/build/libtool --silent --mode=compile /Developer/usr/bin/llvm-gcc-4.2 -I/opt/local/include  -pipe -O2 -arch x86_64  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -DDARWIN_10  -I/opt/local/include  -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os/unix -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/server/mpm/prefork -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/http -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/filters -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/proxy -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/mappers -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/database -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/server -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/proxy/../generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/ssl -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/modules/dav/main  -prefer-non-pic -static -c unixd.c && touch unixd.lo
:info:build libtool: compile: unable to infer tagged configuration
:info:build libtool: compile: specify a tag with `--tag'
:info:build make[3]: *** [unixd.lo] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os/unix'
:info:build make[2]: *** [all-recursive] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os/unix'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19/os'
:info:build make: *** [all-recursive] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.19" && /usr/bin/make -j5 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for apache2): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for apache2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/main.log

Change History (15)

comment:1 Changed 10 years ago by oskari.kokko@…

Cc: oskari.kokko@… added

Cc Me!

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: oskari.kokko@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…

Please remember to cc the maintainer, and to preview and use WikiFormatting (or better, use an attachment for lengthy output). You do not need to be in cc when you are the reporter.

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: apache2 build failedapache2: unable to infer tagged configuration

Rebuild libtool and apr. (I forget which of them is the culprit in this case.)

sudo port -n upgrade force libtool
sudo port -n upgrade force apr

Your libtool and/or apr's libtool were built using a different compiler than the compiler you are trying to use now. Possibly because you built libtool and/or apr before upgrading to Xcode 4.

comment:4 Changed 10 years ago by oskari.kokko@…

Didn't work. After trying what you suggested, uninstalled everything and tried once more, same problem.

comment:5 Changed 10 years ago by oskari.kokko@…

Tried installing with +universal-option, worked that way.

comment:6 Changed 10 years ago by ditikos2@…

I have the same issue on macmini (just updated ports). I have both xcode3 and xcode4 on the machine.

Tried the +universal-option and worked. The problem is that I uninstalled everything before doing that (uninstall everything, clear all ports and reinstall).

One thing to notice also: In my macbookpro (only xcode3), it installed fine yesterday. (macports latest)

comment:7 Changed 10 years ago by srinath@…

I did not reinstall anything. I just tried forcing the build of apache2 with universal option:

sudo port -v -f install apache2 +universal

with success. I am using xcode 4 on snow leopard.

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: hoyomi@… added

Has duplicate #31142.

comment:9 Changed 10 years ago by jendave@…

Cc: jendave@… added

Cc Me!

comment:10 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: jeff@… added

comment:11 Changed 10 years ago by jerome.renard@…

In

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_apache2/apache2/work/httpd-2.2.21/configure

, replace the line:

SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool $(LTFLAGS)'

by this one:

SH_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool $(LTFLAGS) --tag CC'

And relaunch "port upgrade/install apache2"

There is probably a much more elegant solution but this one worked for me and I did not have time to waste on such an issue so I chose the quick and (unfortunately) dirty one.

(Note : exporting LTFLAGS did not work for me)

comment:12 Changed 10 years ago by jmroot (Joshua Root)

Getting the build system to call libtool with the correct --tag argument one way or another is indeed the correct solution.

BTW, is this a duplicate of #30566?

comment:14 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: conradwt@… added

Has duplicate #31687.

comment:15 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #30566.

Note: See TracTickets for help on using tickets.