Opened 8 years ago

Last modified 23 months ago

#30838 new defect

Digikam @2.0.0 hangs at launch.

Reported by: conor.datast0re@… Owned by: jgosmann (Jan Gosmann)
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: tobias.luetticke@…, t.kijas@…, cgilles (HumanDynamo)
Port: digikam

Description

Digikam built without difficulty but hangs on startup, with just the icon in the dock, until you force quit it.

MacPorts is updated to the latest version, and I've done all the launching dbus stuff etc. This seems to effect all KDE applications, at least the ones I've tried.

I'm probably doing something stupid, but I can't think what, any help is very much appreciated, if you need more details just ask.

I'm using OS X 10.6.8 and Xcode 3.2.6.

Change History (14)

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to jan@…

Please remember to cc the maintainer.

comment:2 in reply to:  1 Changed 8 years ago by conor.datast0re@…

Replying to jmr@…:

Please remember to cc the maintainer.

Sorry! Thanks for pointing that out, I should have read the guidelines more carefully, I'll get it right next time.

comment:3 Changed 8 years ago by jgosmann (Jan Gosmann)

First, make sure you have installed the oxygen-icons port. It is a runtime dependency which is missing in the current portfile. I submitted an updated portfile int ticket #30804 which has not been committed to the port tree, yet.

You are also saying that all KDE applications are effected. Therefore this might be the same problem as described in ticket #30578. I solved that problem by running kdeinit4.app:

open /Applications/MacPorts/KDE4/kdeinit4.app

comment:4 Changed 8 years ago by conor.datast0re@…

Ok, I installed oxygen-icons, which took awhile. After starting kdeinit4.app I tried Digikam again - but no joy - it still hangs at startup.

Thank you for you help so far, is there anything else I could try?

comment:5 Changed 8 years ago by jgosmann (Jan Gosmann)

Is it still affecting all KDE applications? If that's the case it might be better to inform the KDE port maintainers.

At the moment I have no idea what else to try. Some more information to track the error down could be helpful (like a debugger backtrace). However, I will not really have any time trying to find a solution for the next 1 to 3 weeks (until I have submitted my Bachelor thesis).

comment:6 Changed 8 years ago by conor.datast0re@…

Yes. I'll try the KDE port maintainers next.

Trying to discover more information about this on the internet I came across a suggestion, rumor really - I may have misunderstood it (I hope so) - that KDE doesn't work well on OS X if there are multiple user accounts - specifically if yours is not the first user account created - as this is my situation, it would be a relief to have this rumor swiftly debunked.

Thank you for all your help, and good luck with your thesis.

Conor

comment:7 Changed 8 years ago by ddennedy (Dan Dennedy)

I maintain the kdenlive port, and this is a common problem for KDE applications. Unfortunately, "launching dbus stuff" is not merely enough. Before launching the dbus --session, you must

chown $USER /Library/LaunchAgents/org.freedesktop.dbus-session.plist

Then, you need to verify it actually all worked with

ps ax | grep [d]bus

which should 2 dbus processes: one with --system and one with --session. Next,

ps ax | grep [k]de

to verify that kdeninit4 and klauncher are running. Unfortunately, it is not always clear why these are failing when they do not launch correctly. For example, I am trying to figure out why the session-level dbus recently stopped working on my system after some upgrades.

Once you get it all working you can make a Login Item for kdeinit4:

http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/mac-os-x-packages-macports

comment:8 in reply to:  7 Changed 8 years ago by conor.datast0re@…

Replying to dan@…: Thank you I appreciate your taking the time to help, I think you're on to something (see below). kdenlive is another application I'd love to get working but I'm focused on installing Digikam at the moment.

ps ax | grep [d]bus

Gives this output;

   50   ??  Ss     0:00.01 /opt/local/bin/dbus-daemon --system --nofork

As you see no sign of a --session dbus.

I take it this is the problem? Hope you can help.

P.S. Should I submit a ticket against dbus, or something else, as this apparently isn't a Digikam problem specifically?

comment:9 Changed 8 years ago by tobias.luetticke@…

Hi there

I'm experiencing exactly the same. Same platform (OS X 10.6.8 and Xcode 3.2.6). digikam and other KDE apps freeze after startup. I get the dock icon, but no actual application window. I have a from-scratch MacPorts install which is also current. I manually added oxygen-icons - didn't make a difference.

I started kdeinit4.app and do get the launcher and kdeninit4 processes. The session-level dbus, however, is not there. --system is present. Would be awesome if anyone could shed some light on this! Thanks a bunch!

comment:10 Changed 8 years ago by tobias.luetticke@…

Cc: tobias.luetticke@… added

Cc Me!

comment:11 Changed 8 years ago by tobias.luetticke@…

Hi folks, update: I built from scratch again. This time, for whatever reason, install of session dbus worked (previously it wasn't listed):

kananaskis:~ tobias$ sudo launchctl list | grep dbus
1016	-	org.freedesktop.dbus-session
381	-	org.freedesktop.dbus-system

Manual start:

kananaskis:~ tobias$ launchctl start org.freedesktop.dbus-session
kananaskis:~ tobias$ ps ax | grep dbus
  381   ??  Ss     0:00.01 /opt/local/bin/dbus-daemon --system --nofork
 1069   ??  S      0:00.01 /opt/local/bin/dbus-daemon --nofork --session
 1073 s000  S+     0:00.00 grep dbus

I ran kdeinit4.app, then started digikam, which froze again and that was it. Appreciate any ideas.

comment:12 Changed 8 years ago by t.kijas@…

Hi I have the similar problem, I installed (or ported, I am newbie in OSX world) digikam as suggested here, but couldn't make it run. So I tried what dan@… suggested but without difference, dbus with --session doesn't run.

The version of digikam is 2.5 and OS X 10.7.3, MacPorts 2.0.3.

my outputs are:

ps ax | grep [d]bus 
43998   ??  Ss     0:00.00 /opt/local/bin/dbus-daemon --system --nofork
75341   ??  S      0:00.08 /opt/local/bin/dbus-daemon --nofork --session

ps ax | grep [k]de 
...too long to copy there but seems OK

sudo launchctl list | grep dbus
43998	-	org.freedesktop.dbus-system

launchctl list | grep dbus
-	1	org.freedesktop.dbus-system
75341	-	org.freedesktop.dbus-session

comment:13 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: t.kijas@… added

Is this still a problem with 2.7.0?

comment:14 Changed 23 months ago by jmroot (Joshua Root)

Cc: caulier.gilles@… added
Note: See TracTickets for help on using tickets.