Opened 9 years ago

Closed 7 years ago

#30882 closed defect (worksforme)

port install py{26,27}-matplotlib hangs on OS X 10.6.8 while staging into destroot

Reported by: henrik_pilz@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: nicholas.clark@…, mf2k (Frank Schima), macports@…, daniel_popescu@…
Port: py26-matplotlib py27-matplotlib

Description (last modified by mf2k (Frank Schima))

the installation of matplotlib for python 2.6 hangs while staging into destroot. I attached the log for port -d install py26-matplotlib.

MacPorts is up to date I made a selfupdate and upgrade outdated before.

I also clean py26-mathplotlib before runnning the install mentioned above.

The last few entries in the log are:

DEBUG: Executing org.macports.destroot (py26-matplotlib)
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/py26-matplotlib/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/py26-matplotlib/work/matplotlib-1.0.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 setup.py --no-user-cfg install --prefix=/opt/local/Library/Frameworks/Python.framework/Versions/2.6 --root=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/py26-matplotlib/work/destroot'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/py26-matplotlib/work/matplotlib-1.0.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 setup.py --no-user-cfg install --prefix=/opt/local/Library/Frameworks/Python.framework/Versions/2.6 --root=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-matplotlib/py26-matplotlib/work/destroot 

Attachments (1)

py26-matplotlib.log (200.6 KB) - added by henrik_pilz@… 9 years ago.
Logfile for port -d install py26-matplotlib

Download all attachments as: .zip

Change History (21)

Changed 9 years ago by henrik_pilz@…

Attachment: py26-matplotlib.log added

Logfile for port -d install py26-matplotlib

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to ram@…
Port: py26-matplotlib added

comment:2 Changed 9 years ago by skymoo (Adam Mercer)

Status: newassigned

py26-matplotlib installs without issue for me, do you see this with any other ports? Is there the same issue with py27-matplotlib

Sorry for the delay but I've been travelling and then my machine was in for repair.

comment:3 Changed 9 years ago by nicholas.clark@…

I have the same problem with the py27-matplotlib, running 10.6.8.

comment:4 Changed 9 years ago by henrik_pilz@…

Try to clean all the build directories for the ports and start the installation again. Might work. It did once for me.

comment:5 Changed 9 years ago by nicholas.clark@…

I gave that a try, but with no effect.

comment:6 Changed 9 years ago by nicholas.clark@…

Cc: nicholas.clark@… added

Cc Me!

comment:7 Changed 9 years ago by mf2k (Frank Schima)

Cc: macsforever2000@… added

Cc Me!

comment:8 Changed 9 years ago by skymoo (Adam Mercer)

I can't reproduce this and there is nothing that I can see that would explain this in the attached logs. Do you have similar problems with any other ports?

comment:9 Changed 9 years ago by skymoo (Adam Mercer)

Cc: macports@… daniel_popescu@… added
Port: py27-matplotlib added
Summary: port install py26-matplotlib hangs on OS X 10.6.8 while staging into destrootport install py{26,27}-matplotlib hangs on OS X 10.6.8 while staging into destroot

Has duplicate: #31639, with the following attachments: install_log.txt main.log

comment:10 Changed 9 years ago by mf2k (Frank Schima)

I see the same problem on 10.7.2 on a new iMac with Xcode 4.2. I'm trying to install with the qt4 variant. Maybe that is the culprit? It seems to hang while running setup.py.

comment:11 in reply to:  10 Changed 9 years ago by daniel_popescu@…

Replying to macsforever2000@…:

I see the same problem on 10.7.2 on a new iMac with Xcode 4.2. I'm trying to install with the qt4 variant. Maybe that is the culprit? It seems to hang while running setup.py.

I am not using qt. Just the basic macosx backend (i.e. default package for Mac OS X). No other package (python, bumpy, scipy, potables, etc) has any issues.... so I assume it's not python related, rather some graphical (PNG, TK?) issue.

comment:12 Changed 9 years ago by mf2k (Frank Schima)

FYI, this is no longer a problem for me. I rebuilt py26-distribute and it builds without the freeze now.

comment:13 Changed 9 years ago by mf2k (Frank Schima)

Port: py26-matplotlib, py27-matplotlibpy26-matplotlib py27-matplotlib

comment:14 Changed 9 years ago by mf2k (Frank Schima)

I have fixed this problem by uninstalling all ports and reinstalling from scratch. It's possible that some port requires a revision bump, but I was not able to figure out which one after spending hours trying different ports. Perhaps we can close this as "works for me"?

comment:15 Changed 9 years ago by skymoo (Adam Mercer)

Resolution: worksforme
Status: assignedclosed

comment:16 Changed 7 years ago by denpashogai@…

I'm getting this on OS X 10.5. Gets to "Staging py27-matplotlib into destroot" and seems to stay there forever (at least 10 minutes, with no noticeable CPU load).

comment:17 Changed 7 years ago by skymoo (Adam Mercer)

Resolution: worksforme
Status: closedreopened

comment:18 Changed 7 years ago by skymoo (Adam Mercer)

Owner: changed from ram@… to sean@…
Status: reopenednew

Assign to current maintainer

comment:19 Changed 7 years ago by paulries@…

I just had this problem when upgrading matplotlib on a Mac with 10.6.8. There were at least two factors which I think were responsible for the hang-up:

  • I was running python w/matplotlib while installing
  • the installing left processes running and hung in the background after CTRL+C'ing the port upgrade outdated command

I tried ps -A | grep python and killing the results, as well as clearing the install, but that didn't seem to work. However, rebooting the machine and then running port upgrade py27-matplotlib succeeded. I suspect there was a hung process somewhere without python in the name that was preventing matplotlib from being installed and rebooting killed whatever it was.

comment:20 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: worksforme
Status: newclosed

Closing this as "works for me".

Note: See TracTickets for help on using tickets.