Opened 10 years ago

Closed 10 years ago

#30926 closed defect (duplicate)

ManOpen @2.5.1 build error under Mac OS X Lion

Reported by: thomas@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: waqar@…
Port: ManOpen

Description (last modified by ryandesign (Ryan Schmidt))

ManOpen no longer compiles under Mac OS X Lion (main.log):

version:1
:debug:main Executing org.macports.main (manopen)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Skipping completed org.macports.archivefetch (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.configure (manopen)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Mon Aug 22 11:27:28 CEST 2011
:notice:build --->  Building manopen
:debug:build Executing org.macports.build (manopen)
:debug:build port disallows a parallel build
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1" && /usr/bin/make -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1" && /usr/bin/make -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/ManOpen/work/ManOpen-2.5.1'
:info:build == Making all for i386 in ManOpen openman.tproj ==
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/ManOpen/work/ManOpen-2.5.1/ManOpen'
:info:build == Making ManOpen for i386 ==
:info:build Pre-build setup...
:info:build /bin/rm -f /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/derived_src/TrustedPrecomps.txt
:info:build ......skipping cat2html.tproj
:info:build ......skipping cat2rtf.tproj
:info:build Building...
:info:build ......skipping cat2html.tproj
:info:build ......skipping cat2rtf.tproj
:info:build -n
:info:build Copying English resources...
:info:build /usr/bin/cc -arch i386 -Os  -Wmost  -g  -fno-common -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/ProjectHeaders -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.app/PrivateHeaders -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/Headers -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/derived_src/ManOpen -I. -pipe        -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/Headers -I/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/PrivateHeaders -F/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1      -ObjC       -c -o /opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/objects-optimized/ManOpen/ManDocument.i386.o ManDocument.m
:info:build In file included from ManDocument.m:2:
:info:build ManDocument.h:16: error: expected specifier-qualifier-list before ‘NSMutableArray’
:info:build ManDocument.h:17: error: expected specifier-qualifier-list before ‘NSMutableArray’
:info:build ManDocument.m: In function ‘-[ManDocument dealloc]’:
:info:build ManDocument.m:70: error: ‘sections’ undeclared (first use in this function)
:info:build ManDocument.m:70: error: (Each undeclared identifier is reported only once
:info:build ManDocument.m:70: error: for each function it appears in.)
:info:build ManDocument.m: In function ‘-[ManDocument displayName]’:
:info:build ManDocument.m:85: warning: ‘fileName’ is deprecated (declared at /System/Library/Frameworks/AppKit.framework/Headers/NSDocument.h:723)
:info:build ManDocument.m: In function ‘-[ManDocument setupSectionPopup]’:
:info:build ManDocument.m:108: error: ‘sections’ undeclared (first use in this function)
:info:build ManDocument.m: In function ‘-[ManDocument addSectionHeader:range:]’:
:info:build ManDocument.m:124: error: ‘sections’ undeclared (first use in this function)
:info:build ManDocument.m:130: error: ‘sectionRanges’ undeclared (first use in this function)
:info:build ManDocument.m: In function ‘-[ManDocument showData]’:
:info:build ManDocument.m:164: error: ‘sections’ undeclared (first use in this function)
:info:build ManDocument.m:166: error: ‘sectionRanges’ undeclared (first use in this function)
:info:build ManDocument.m: In function ‘-[ManDocument windowControllerDidLoadNib:]’:
:info:build ManDocument.m:369: warning: class 'ManDocument' does not implement the 'NSWindowDelegate' protocol
:info:build ManDocument.m: In function ‘-[ManDocument displaySection:]’:
:info:build ManDocument.m:401: error: ‘sectionRanges’ undeclared (first use in this function)
:info:build ManDocument.m: In function ‘-[ManDocument printShowingPrintPanel:]’:
:info:build ManDocument.m:427: warning: ‘setShowPanels:’ is deprecated (declared at /System/Library/Frameworks/AppKit.framework/Headers/NSPrintOperation.h:157)
:info:build make[1]: *** [/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1/ManOpen.build/objects-optimized/ManOpen/ManDocument.i386.o] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/ManOpen/work/ManOpen-2.5.1/ManOpen'
:info:build make: *** [all@ManOpen] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/ManOpen/work/ManOpen-2.5.1'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/work/ManOpen-2.5.1" && /usr/bin/make -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for manopen): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for manopen is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_ports_aqua_ManOpen/manopen/main.log

Change History (1)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: waqar@… added
Description: modified (diff)
Port: ManOpen added
Resolution: duplicate
Status: newclosed

Please use WikiFormatting, fill in the Port field and Cc the port's maintainer, and most importantly, search for existing tickets before filing a new one; this is a duplicate of #30380.

Note: See TracTickets for help on using tickets.