Opened 10 years ago

Closed 9 years ago

#30983 closed defect (fixed)

multimedia/XviD libxvidcore.a mmx error

Reported by: rmstonecipher@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: develop@…, dbevans (David B. Evans)
Port: XviD

Description

When attempting to build gst-plugins-bad +universal, ld fails on the i386 part of libxvidcore.a:

:info:build libtool: link: /Developer/usr/bin/llvm-gcc-4.2  -o .libs/libgstxvid.so -bundle  .libs/libgstxvid_la-gstxvidenc.o .libs/libgstxvid_la-gstxviddec.o .libs/libgstxvid_la-gstxvid.o   -L/opt/local/lib /opt/local/lib/libgstreamer-0.10.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libxml2.dylib /opt/local/lib/libgthread-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lxvidcore  -O2 -arch x86_64 -arch i386 -arch x86_64 -arch i386   -framework Carbon -Wl,-exported_symbols_list,.libs/libgstxvid-symbols.expsym
:info:build ld: illegal text reloc to anon from /opt/local/lib/libxvidcore.a(cbp_mmx.o) in _calc_cbp_mmx for architecture i386
:info:build collect2: ld returned 1 exit status
:info:build lipo: can't open input file: /var/tmp//ccdORhfw.out (No such file or directory)
:info:build make[3]: *** [libgstxvid.la] Error 1

A full build log is attached.
If this is a problem with gst-plugins-bad rather than xvid please edit the ticket summary to fit.

Attachments (1)

gst-plugins-bad_main.log (1.2 MB) - added by rmstonecipher@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by rmstonecipher@…

Attachment: gst-plugins-bad_main.log added

comment:1 Changed 10 years ago by develop@…

Cc: develop@… added

Cc Me!

comment:2 Changed 9 years ago by dbevans (David B. Evans)

Cc: devans@… added
Resolution: fixed
Status: newclosed

The problem is that libtool, seeing -lxvidcore, is linking against the static library (/opt/local/lib/libxvidcore.a) rather than the dynamic one (/opt/test/lib/libxvidcore.4.dylib). No libxvidcore.dylib (usually a symbolic link to the versioned library) is provided by XviD.

Fix to XviD committed in r87730 which installs the "missing link."

gst-plugins-bad now builds +universal for me.

You may want to increment gst-plugins-bad's revision to ensure that all builds are now using the dynamic library.

Note: See TracTickets for help on using tickets.