Opened 8 years ago

Closed 8 years ago

#31142 closed defect (duplicate)

Apache2 2.2.20 upgrade error

Reported by: hoyomi@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.2
Keywords: Cc:
Port: apache2

Description

I was trying to upgrade apache2 from 2.2.19 to 2.2.20 when this error occurred. I am using MacPorts 2.0.2 on Mac OS X 10.6.8 Intel Core 2 Duo 2.53 GHz.

Error message:

$ sudo port upgrade outdated
Password:
--->  Computing dependencies for apache2
--->  Fetching archive for apache2
--->  Attempting to fetch apache2-2.2.20_0+preforkmpm.darwin_10.x86_64.tbz2 from http://packages.macports.org/apache2
--->  Fetching apache2
--->  Verifying checksum(s) for apache2
--->  Extracting apache2
--->  Applying patches to apache2
--->  Configuring apache2
--->  Building apache2
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for apache2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

If I check the port info, it shows the version 2.2.20. Yet, in phpinfo(), it shows 2.2.19.

$ port info apache2
apache2 @2.2.20 (www)
Variants:             eventmpm, no_startupitem, openldap, [+]preforkmpm, universal, workermpm

Description:          Apache is an HTTP server designed as a plug-in replacement for the NCSA server version 1.3 (or 1.4). It fixes numerous bugs in the NCSA server and includes
                      many frequently requested new features, and has an API which allows it to be extended to meet users' needs more easily.
Homepage:             http://httpd.apache.org/

Library Dependencies: apr, apr-util, expat, openssl, pcre, perl5
Conflicts with:       apache
Platforms:            darwin, freebsd, openbsd
License:              unknown
Maintainers:          ryandesign@macports.org, openmaintainer@macports.org

Here is the main.log

version:1
:msg:main --->  Computing dependencies for apache2:info:main .:debug:main Checking for conflicts against apache2
:debug:main Searching for dependency: apache
:debug:main Didn't find receipt, going to depspec regex for: apache
:debug:main Searching for dependency: apr
:debug:main Found Dependency: receipt exists for apr
:debug:main Searching for dependency: apr-util
:debug:main Found Dependency: receipt exists for apr-util
:debug:main Searching for dependency: expat
:debug:main Found Dependency: receipt exists for expat
:debug:main Searching for dependency: openssl
:debug:main Found Dependency: receipt exists for openssl
:debug:main Searching for dependency: pcre
:debug:main Found Dependency: receipt exists for pcre
:debug:main Searching for dependency: perl5
:debug:main Found Dependency: receipt exists for perl5
:msg:main 
:debug:main Executing org.macports.main (apache2)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 502
:debug:main Skipping completed org.macports.archivefetch (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.configure (apache2)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Tue Sep  6 12:48:10 EDT 2011
:notice:build --->  Building apache2
:debug:build Executing org.macports.build (apache2)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20" && /usr/bin/make -j2 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20" && /usr/bin/make -j2 -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20'
:info:build Making all in srclib
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/srclib'
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/srclib'
:info:build Making all in os
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os'
:info:build Making all in unix
:info:build make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os/unix'
:info:build make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os/unix'
:info:build /opt/local/share/apr-1/build/libtool --silent --mode=compile /Developer/usr/bin/llvm-gcc-4.2 -I/opt/local/include  -pipe -O2 -arch x86_64  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp -DDARWIN_10  -I/opt/local/include  -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os/unix -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/server/mpm/prefork -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/http -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/filters -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/proxy -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/mappers -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/database -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/server -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/proxy/../generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/ssl -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/modules/dav/main  -prefer-non-pic -static -c unixd.c && touch unixd.lo
:info:build libtool: compile: unable to infer tagged configuration
:info:build libtool: compile: specify a tag with `--tag'
:info:build make[3]: *** [unixd.lo] Error 1
:info:build make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os/unix'
:info:build make[2]: *** [all-recursive] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os/unix'
:info:build make[1]: *** [all-recursive] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20/os'
:info:build make: *** [all-recursive] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/work/httpd-2.2.20" && /usr/bin/make -j2 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for apache2): org.macports.install org.macports.build org.macports.destroot
:notice:build Log for apache2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_apache2/apache2/main.log

Change History (2)

comment:1 Changed 8 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to ryandesign@…

Looks like a duplicate of #30744 to me.

Also, please remember to assign to or cc the maintainer.

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.