Opened 9 years ago

Closed 9 years ago

#31197 closed defect (duplicate)

go @57.1, Revision 2 Build failure

Reported by: panayotis@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: lion Cc: singingwolfboy@…
Port: go

Description (last modified by ryandesign (Ryan Schmidt))

Go fails to build on Lion, with the following error log:

:info:build %%%% making pkg %%%%
:info:build 
:info:build install archive/tar
:info:build install archive/zip
:info:build install asn1
:info:build install big
:info:build INSTALL FAIL archive/zip
:info:build INSTALL FAIL archive/tar
:info:build INSTALL FAIL asn1
:info:build INSTALL FAIL big
:info:build 6g  -o _go_.6 common.go reader.go writer.go 
:info:build reader.go:11: can't find import: bytes
:info:build make[1]: *** [_go_.6] Error 1
:info:build 6g  -o _go_.6 reader.go struct.go 
:info:build reader.go:15: can't find import: bufio
:info:build make[1]: *** [_go_.6] Error 1
:info:build 6g  -o _go_.6 arith.go arith_decl.go int.go nat.go rat.go 
:info:build int.go:10: can't find import: fmt
:info:build make[1]: *** [_go_.6] Error 1
:info:build 6g  -o _go_.6 asn1.go common.go marshal.go 
:info:build asn1.go:23: can't find import: fmt
:info:build make[1]: *** [_go_.6] Error 1
:info:build make: *** [big.install] Error 1
:info:build make: *** Waiting for unfinished jobs....
:info:build make: *** [asn1.install] Error 1
:info:build make: *** [archive/zip.install] Error 1
:info:build make: *** [archive/tar.install] Error 1
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_go/go/work/go-57.1/src" && ./make.bash " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for go): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for go is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_go/go/main.log

Attachments (1)

main.log (125.5 KB) - added by panayotis@… 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by panayotis@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: lion added; Lion removed
Resolution: duplicate
Status: newclosed

Use WikiFormatting please. Also please search for existing tickets before filing a new one. This is a duplicate of #30319.

Note: See TracTickets for help on using tickets.