New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #31261 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

root: configure fails when file port is installed and xorg-libX11 is universal

Reported by: ryandesign@… Owned by: jonesc@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: mattiafrancescomoro@…
Port: root

Description

The root port fails to install if the file port is installed, and the xorg-libX11 port is installed with the universal variant.

The root port's configure script attempts to verify that its dependencies are installed for the correct architectures. While this is a fine goal, it does so using the file command and grepping the output for "64-bit". Apple's version of the file command shipped with Mac OS X does have this output for universal and non-universal 64-bit files, but the file port's file command only does this for non-universal files; it doesn't understand universal files.

The simplest solution for us is to just rip out this architecture verification code from root's configure script, since MacPorts base already includes architecture verification code.

Change History

comment:1 Changed 4 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate

Sorry, duplicate of #31260.

comment:2 Changed 4 years ago by jonesc@…

Ok, this appears to be outside the realms of the various options I tried.

If I follow correctly, the real problem is with MacPorts 'file' port, so we the simplest solution is to get wait for this to be fixed ?

Getting a fix into ROOT itself will be difficult I think ...

Chris

comment:3 Changed 4 years ago by ryandesign@…

#11747 has been open for 4.5 years; I doubt it will be fixed soon.

Whether the developers of root wish to make their software work or not is up to them; if they don't, we can patch it locally so that it works for us.

comment:4 Changed 4 years ago by jonesc@…

OK....

The age of the bug report against file is not really relevant, regardless, it is still it seems the reason for the problems with root.

if there is a way to patch this in root, let me know and I'll give it a try.

cheers Chris

comment:5 Changed 4 years ago by ryandesign@…

There are a couple approaches you could use.

  1. call /usr/bin/file instead of file
  2. delete the entire function that involves the calls to file (or rather replace them with no-ops that always set the flag variable to true) since they're not needed within the confines of MacPorts
Note: See TracTickets for help on using tickets.