Opened 8 years ago

Closed 8 years ago

#31263 closed defect (fixed)

qlandkartegt 1.2.3: missing dependencies

Reported by: mklein-de (Michael Klein) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc:
Port: qlandkartegt

Description

qlandkartegt uses gpsd and dmtx libraries if present, should be added as depenencies

Attachments (1)

Portfile.diff (564 bytes) - added by mklein-de (Michael Klein) 8 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Ok, but what if the dependencies are not present? Would the build succeed? If so, the revision needs to be increased when the dependencies are added. Actually increasing the revision is a good idea regardless, so the dependencies get recorded correctly in the registry.

comment:2 in reply to:  1 Changed 8 years ago by mklein-de (Michael Klein)

Replying to ryandesign@…:

Ok, but what if the dependencies are not present? Would the build succeed?

Yes, the two libraries are optional.

Changed 8 years ago by mklein-de (Michael Klein)

Attachment: Portfile.diff added

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.