Opened 9 years ago

Closed 9 years ago

#31302 closed defect (fixed)

Skrooge - Cannot talk to klauncher

Reported by: nmed27@… Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: pixilla (Bradley Giesbrecht), ak.ml@…
Port: skrooge

Description

Below error received when performing import operations from Skrooge -

Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files.

Attachments (1)

Screen shot 2011-10-08 at 12.35.32 PM.png (214.8 KB) - added by nmed27@… 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by nmed27@…

The following ports are currently installed:

aspell @0.60.6_4+nonls (active) aspell-dict-en @7.1_0 (active) atk @1.32.0_0 (active) attica @0.2.0_1 (active) autoconf @2.68_2 (active) automake @1.11.1_0 (active) automoc @0.9.88_3 (active) avahi @0.6.30_1+python27 (active) bison @2.5_0 (active) bzip2 @1.0.6_0 (active) cairo @1.10.2_4+x11 (active) clucene @0.9.21b_0 (active) cmake @2.8.5_0 (active) cppunit @1.12.1_0 (active) curl @7.22.0_0+ssl (active) curl-ca-bundle @7.22.0_0 (active) cyrus-sasl2 @2.1.23_3+kerberos (active) db46 @4.6.21_6+java (active) dbus @1.4.12_0 (active) dbus-glib @0.94_0 (active) dbus-python27 @0.84.0_0 (active) dbusmenu-qt @0.6.2_2 (active) dirac @1.0.2_1 (active) docbook-xml @5.0_0 (active) docbook-xml-4.1.2 @4.1.2_1 (active) docbook-xml-4.2 @4.2_0 (active) docbook-xml-4.3 @4.3_0 (active) docbook-xml-4.4 @4.4_0 (active) docbook-xml-4.5 @4.5_0 (active) docbook-xml-5.0 @5.0_0 (active) docbook-xsl @1.76.1_0 (active) docbook-xsl-ns @1.76.1_0 (active) enchant @1.6.0_1 (active) exiv2 @0.21.1_0 (active) expat @2.0.1_1 (active) ffmpeg @0.7.4_0 (active) fftw-3 @3.3_0 (active) flex @2.5.35_1 (active) fontconfig @2.8.0_0 (active) freetype @2.4.6_0 (active) gawk @4.0.0_0 (active) gdbm @1.9.1_0 (active) gdk-pixbuf2 @2.22.1_1 (active) getopt @1.1.4_1 (active) gettext @0.18.1.1_2 (active) giflib @4.1.6_1 (active) git-core @1.7.6.1_1+doc+pcre+python27 (active) glib2 @2.28.8_0 (active) gmake @3.82_0 (active) gmp @5.0.2_1 (active) gnome-common @2.28.0_0 (active) gnome-doc-utils @0.20.6_0+python27 (active) gnupg @1.4.11_1 (active) gperf @3.0.4_2 (active) grantlee @0.1.9_0 (active) gsed @4.2.1_1 (active) gtk-doc @1.18_0+python27 (active) gtk2 @2.24.6_0+x11 (active) help2man @1.40.4_1 (active) hicolor-icon-theme @0.12_0 (active) hunspell @1.3.2_0 (active) icu @4.6.1_0 (active) ilmbase @1.0.2_0 (active) intltool @0.40.6_1 (active) iso-codes @3.27.1_0 (active) jasper @1.900.1_7 (active) jpeg @8c_0 (active) kde4-runtime @4.7.1_0 (active) kdelibs4 @4.7.1_0 (active) kerberos5 @1.7.2_0 (active) lame @3.98.4_0 (active) lcms @1.19_2 (active) libart_lgpl @2.3.21_0 (active) libdaemon @0.14_0 (active) libffi @3.0.9_0 (active) libglade2 @2.6.4_3 (active) libiconv @1.14_0 (active) libidn @1.22_0 (active) libiodbc @3.52.7_0 (active) liblzma @5.0.3_0 (active) libmng @1.0.10_2 (active) libofx @0.9.4_0 (active) libogg @1.3.0_0 (active) libpixman @0.22.2_1 (active) libpng @1.4.8_0 (active) libsdl @1.2.14_9+x11 (active) libssh @0.5.0_0 (active) libtheora @1.1.1_0 (active) libtool @2.4_1 (active) libusb @1.0.8_0 (active) libusb-compat @0.1.3_0 (active) libvorbis @1.3.2_0 (active) libvpx @0.9.7-p1_0 (active) libxml2 @2.7.8_0 (active) libxslt @1.1.26_0 (active) m4 @1.4.16_0 (active) mpfr @3.0.1-p3_0 (active) ncurses @5.9_1 (active) ncursesw @5.8_0 (active) openexr @1.6.1_1 (active) openldap @2.4.21_3 (active) openslp @1.2.1_2 (active) opensp @1.5.2_0 (active) openssl @1.0.0e_0 (active) orc @0.4.14_0 (active) oxygen-icons @4.7.1_0 (active) p5.12-error @0.170.160_3 (active) p5.12-getopt-long @2.380.0_2 (active) p5.12-locale-gettext @1.50.0_6 (active) p5.12-pathtools @3.330.0_2 (active) p5.12-scalar-list-utils @1.230.0_2 (active) p5.12-xml-parser @2.400.0_2 (active) pango @1.28.4_1+x11 (active) pcre @8.12_0 (active) perl5 @5.12.3_1+perl5_12 (active) perl5.12 @5.12.3_2 (active) phonon @4.4.2_3 (active) pkgconfig @0.26_0 (active) popt @1.16_0 (active) py27-cairo @1.8.10_1 (active) py27-distribute @0.6.21_0 (active) py27-gobject @2.26.0_1 (active) py27-gtk @2.22.0_1 (active) py27-libxml2 @2.7.8_0 (active) py27-nose @1.1.2_0 (active) py27-numpy @1.6.1_0 (active) py27-py @1.1.1_0 (active) python27 @2.7.2_1 (active) python_select @0.3_1 (active) qca @2.0.2_6 (active) qca-ossl @2.0.0-beta3_3 (active) qimageblitz @0.0.6_0 (active) qjson @0.7.1_1 (active) qt4-mac @4.7.4_1+quartz (active) raptor @1.4.21_2 (active) raptor2 @2.0.4_1 (active) rarian @0.8.1_0 (active) rasqal @0.9.26_2 (active) readline @6.2.000_0 (active) redland @1.0.14_0+db46 (active) rsync @3.0.8_0 (active) schroedinger @1.0.10_1 (active) shared-desktop-ontologies @0.8.0_0 (active) shared-mime-info @0.90_0 (active) skrooge @0.9.98_0 (active) soprano @2.7.0_0 (active) speex @1.2rc1_0 (active) sqlite3 @3.7.7.1_0 (active) strigi @0.7.5_1 (active) texi2html @5.0_0 (active) texinfo @4.13_2 (active) tiff @3.9.5_0 (active) virtuoso @6.1.3_0 (active) x264 @20110628_0 (active) Xft2 @2.2.0_0 (active) xmlcatmgr @2.2_1 (active) xorg-bigreqsproto @1.1.1_0 (active) xorg-compositeproto @0.4.2_0 (active) xorg-damageproto @1.2.1_0 (active) xorg-fixesproto @5.0_0 (active) xorg-inputproto @2.0.2_0 (active) xorg-kbproto @1.0.5_0 (active) xorg-libice @1.0.7_0 (active) xorg-libpthread-stubs @0.3_0 (active) xorg-libsm @1.2.0_0 (active) xorg-libX11 @1.4.4_0 (active) xorg-libXau @1.0.6_0 (active) xorg-libxcb @1.7_0+python27 (active) xorg-libXcomposite @0.4.3_0 (active) xorg-libXcursor @1.1.12_0 (active) xorg-libXdamage @1.1.3_0 (active) xorg-libXdmcp @1.1.0_0 (active) xorg-libXext @1.3.0_0 (active) xorg-libXfixes @5.0_0 (active) xorg-libXi @1.4.3_0 (active) xorg-libXinerama @1.1.1_0 (active) xorg-libXrandr @1.3.2_0 (active) xorg-randrproto @1.3.2_0 (active) xorg-renderproto @0.11.1_0 (active) xorg-util-macros @1.15.0_0 (active) xorg-xcb-proto @1.6_0+python27 (active) xorg-xcb-util @0.3.8_0 (active) xorg-xcmiscproto @1.2.1_0 (active) xorg-xextproto @7.2.0_0 (active) xorg-xf86bigfontproto @1.2.0_0 (active) xorg-xineramaproto @1.2.1_0 (active) xorg-xproto @7.0.22_0 (active) xorg-xtrans @1.2.6_0 (active) xrender @0.9.6_0 (active) XviD @1.3.2_1 (active) xz @5.0.3_0 (active) yasm @1.1.0_0 (active) zlib @1.2.5_0 (active)

comment:2 Changed 9 years ago by mf2k (Frank Schima)

Cc: pixilla@… added
Owner: changed from macports-tickets@… to mk@…
Port: skrooge added
Priority: HighNormal

comment:3 Changed 9 years ago by ak.ml@…

Cc: ak.ml@… added

Cc Me!

comment:4 Changed 9 years ago by mkae (Marko Käning)

Perhaps you try

http://trac.macports.org/ticket/30838

as described in http://trac.macports.org/ticket/30838#comment:3

comment:5 Changed 9 years ago by mkae (Marko Käning)

Is this still an issue?

comment:6 in reply to:  5 Changed 9 years ago by ak.ml@…

Replying to mk@…:

Is this still an issue?

It's the same issue as #31332 and #31253. All three tickets can be closed.

comment:7 Changed 9 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Thanks ak.ml. I wasn't sure whether those tickets really are one and the same.

Changed 9 years ago by nmed27@…

comment:8 Changed 9 years ago by nmed27@…

Resolution: fixed
Status: closedreopened

Thanks for your assistance, however none of it seems to work and the issue still remains unresolved.

The applications launches just and doesn't crash at any time. Its when I try to perform an "import" operation, the directory listing doesn't appear and the below error message is thrown -

"Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files."

I have attached a screenshot of the error message for reference.

comment:9 in reply to:  8 Changed 9 years ago by ak.ml@…

Replying to nmed27@…:

Thanks for your assistance, however none of it seems to work and the issue still remains unresolved.

The applications launches just and doesn't crash at any time. Its when I try to perform an "import" operation, the directory listing doesn't appear and the below error message is thrown -

"Could not start process Cannot talk to klauncher: The name org.kde.klauncher was not provided by any .service files."

I have attached a screenshot of the error message for reference.

The problem you're describing was solved in #31332 by fixing kdelibs4.
Since your first log indicates that kdelibs4 and skrooge are now outdated, could you please confirm which versions are currently installed on your system?

$ port -v installed kdelibs4 skrooge

And don't forget to use WikiFormatting.

comment:10 Changed 9 years ago by mkae (Marko Käning)

Any news on this issue, nmed27? Could you resolve it in the meantime?

comment:11 Changed 9 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed

I think this can be considered closed. Please re-open if the problem still exists.

Note: See TracTickets for help on using tickets.