Opened 8 years ago

Closed 8 years ago

#31326 closed defect (fixed)

eggdrop @1.6.20 - linker error

Reported by: yr.retarded@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: lion Cc: ryandesign (Ryan Schmidt), dreness (Andre LaBranche)
Port: eggdrop

Description

I encountered a linker error after building eggdrop today on Lion (10.7.1). I performed a selfupdate before building. Most recent Xcode installed. Here's the relevant information:

Darwin Kernel Version 11.1.0 gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)

:info:build ---------- Yeah! That's the compiling, now the linking! ----------
:info:build 
:info:build Linking eggdrop (static version).
:info:build 
:info:build /Developer/usr/bin/llvm-gcc-4.2 -o ../eggdrop bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o dcc.o dccutil.o dns.o flags.o language.o match.o main.o mem.o misc.o misc_file.o modules.o net.o rfc1459.o tcl.o tcldcc.o tclhash.o tclmisc.o tcluser.o userent.o userrec.o users.o mod/*.o -L/usr/lib -ltcl8.5 -lm -ldl  -lpthread md5/md5c.o compat/*.o `cat mod/mod.xlibs`
:info:build Undefined symbols for architecture x86_64:
:info:build   "_res_9_init", referenced from:
:info:build       _dns_start in dns.o
:info:build   "_res_9_dn_expand", referenced from:
:info:build       _dns_socket in dns.o
:info:build   "_res_9_mkquery", referenced from:
:info:build       _dorequest in dns.o
:info:build ld: symbol(s) not found for architecture x86_64

Change History (1)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… dre@… added
Resolution: fixed
Status: newclosed

I imagine r84162 will fix this. Please re-open if not.

Note: See TracTickets for help on using tickets.