Opened 10 years ago

Closed 9 years ago

#31591 closed defect (fixed)

the most recent version of rebar is hosted on github

Reported by: ci42 Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: mail@…, kenny.macdermid@…
Port: rebar

Description

The most recent version of rebar is hosted on github: https://github.com/basho/rebar

The version on bitbucket seems to be outdated.

Attachments (3)

Portfile (1.4 KB) - added by kenny.macdermid@… 10 years ago.
Portfile to use github
Portfile.diff (854 bytes) - added by mail@… 9 years ago.
Diff for port with change to github and a new version number
Portfile.2.diff (916 bytes) - added by mail@… 9 years ago.
Added a commit id for reproducable builds

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by kenny.macdermid@…

Version from bitbucket is no longer available. I'll attach an updated Portfile that works for me.

Changed 10 years ago by kenny.macdermid@…

Attachment: Portfile added

Portfile to use github

comment:2 Changed 10 years ago by kenny.macdermid@…

Cc: kenny.macdermid@… added

Cc Me!

Changed 9 years ago by mail@…

Attachment: Portfile.diff added

Diff for port with change to github and a new version number

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Note that pulling from whatever master is at the time of pulling is usually not how we handle packaging git sources, since we aim for reproducible builds. Please add a suitable commit-ish as specified by the git manual as "git.branch <commitish>" to the Portfile.

You can also simplify your effort by using the recently created github portgroup trunk/dports/_resources/port1.0/group/github-1.0.tcl:

github.setup basho rebar <commitish>

# github.setup sets version to it's third argument, but sha1 hashes aren't strictly increasing and thus can't be used as version
version <some version number, which should be always increasing, e.g. date +%Y-%m-%d>

and instead you can drop name, homepage, fetch.*, git.* and you automatically get livecheck. Also consider using the tag RELEASE-1.

Changed 9 years ago by mail@…

Attachment: Portfile.2.diff added

Added a commit id for reproducable builds

comment:4 Changed 9 years ago by mail@…

The tag RELEASE-1 is very old (18.12.2009), so it is not a good idea to take that tag :(. I have added the current commit id and i will check from time to time, if there is a newer version available, test it and add a new ticket with the diff.

That was the reason, why i took the master.

comment:5 Changed 9 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to cal@…
Status: newassigned

comment:6 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: assignedclosed

Commited in r89708.

Note: See TracTickets for help on using tickets.