New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #31649 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

libsdl building for i386 failed with clang segmentation fault

Reported by: khoyee@… Owned by: jmr@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: clang Cc:
Port: libsdl

Description

Trying to upgrade libsdl on Lion with the latest XCode 4.2 (Build 4D199) and the following clang version results in below error:

clang version:

Apple clang version 3.0 (tags/Apple/clang-211.10.1) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.2.0
Thread model: posix

port error:

--->  Computing dependencies for libsdl
--->  Building libsdl
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for libsdl is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libsdl/libsdl/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

The log file says:

:info:build libtool: compile:  /Developer/usr/bin/clang -pipe -O2 -arch x86_64 -arch i386 -I/opt/local/include -I./include -D_GNU_SOURCE=1 -DTARGET_API_MAC_CARBON -DTARGET_API_MAC_OSX -fvisibility=hidden -I/opt/local/include -DXTHREADS -D_THREAD_SAFE -force_cpusubtype_ALL -fpascal-strings -c ./src/video/SDL_blit_1.c -o build/SDL_blit_1.o >/dev/null 2>&1
:info:build clang: error: unable to execute command: Segmentation fault: 11
:info:build clang: error: clang frontend command failed due to signal 2 (use -v to see invocation)
:info:build make: *** [build/SDL_audio.lo] Error 1

Attachments

main.log (80.9 KB) - added by khoyee@… 3 years ago.

Change History

comment:1 Changed 3 years ago by ryandesign@…

  • Keywords libsdl, removed
  • Owner changed from macports-tickets@… to jmr@…
  • Port changed from lisdl to libsdl

Clean and try again. If it fails again, please attach the main.log.

sudo port clean libsdl
sudo port install libsdl

Changed 3 years ago by khoyee@…

comment:2 Changed 3 years ago by khoyee@…

Thanks.

But that doesn't help.

Log attached.

comment:3 Changed 3 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from libsdl failed with clang segmentation fault to libsdl building for i386 failed with clang segmentation fault

Worked around in r86009. Bug filed with Apple: rdar://problem/10302909

I encourage others to file their own bug report with Apple, as they give greater priority to bugs reported by more people.

comment:4 Changed 2 years ago by jmr@…

JFYI, my radar was a duplicate of rdar://problem/9967101

comment:5 Changed 2 years ago by nickbroon@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm still seeing this problem. I'm using XCode 4.2.1. Does the work around need enhanced to check for this version too?

comment:6 Changed 2 years ago by jmr@…

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.