Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#3166 closed defect (duplicate)

Error building qt3 on Tiger

Reported by: dhjr@… Owned by: rshaw@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

c++ -c -fPIC -fno-common -pipe -fno-exceptions -I/Users/dhjr/darwinports/dports/x11/qt3/work/qt-x11-free-3.1.2/include -I/opt/local/include -I/usr/X11R6/include/freetype2 -Wall -W -Os -fPIC -DQT_SHARED -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQ_OS_DARWIN -DQ_OS_FREEBSD -DQT_THREAD_SUPPORT -DQT_NO_NIS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DQT_NO_IMAGEIO_MNG -DQT_NO_IMAGEIO_JPEG -DQT_NO_IMAGEIO_PNG -DQT_BUILTIN_GIF_READER=1 -DQT_NO_STYLE_MAC -DQT_NO_STYLE_AQUA -DQT_NO_STYLE_INTERLACE -DQT_NO_STYLE_WINDOWSXP -DQT_NO_STYLE_COMPACT -I/Users/dhjr/darwinports/dports/x11/qt3/work/qt-x11-free-3.1.2/mkspecs/darwin-g++ -I. -I/opt/local/include/freetype2 -I/opt/local/include/qt -I../include -I/usr/X11R6/include -I/usr/X11R6/include -I.moc/release-shared-mt/ -o .obj/release-shared-mt/qsocketdevice_unix.o network/qsocketdevice_unix.cpp network/qsocketdevice_unix.cpp: In function `int qt_socket_accept(int, sockaddr*, int*)': network/qsocketdevice_unix.cpp:47: error: invalid conversion from 'int*' to 'socklen_t*' network/qsocketdevice_unix.cpp:47: error: initializing argument 3 of 'int accept(int, sockaddr*, socklen_t*)' network/qsocketdevice_unix.cpp: In member function `int QSocketDevice::option(QSocketDevice::Option) const': network/qsocketdevice_unix.cpp:258: error: invalid conversion from 'int*' to 'socklen_t*' network/qsocketdevice_unix.cpp:258: error: initializing argument 5 of 'int getsockopt(int, int, int, void*, socklen_t*)' network/qsocketdevice_unix.cpp: In member function `virtual Q_LONG QSocketDevice::readBlock(char*, Q_ULONG)': network/qsocketdevice_unix.cpp:660: error: invalid conversion from 'int*' to 'socklen_t*' network/qsocketdevice_unix.cpp:660: error: initializing argument 6 of 'ssize_t recvfrom(int, void*, size_t, int, sockaddr*, socklen_t*)' network/qsocketdevice_unix.cpp: In member function `void QSocketDevice::fetchConnectionParameters()': network/qsocketdevice_unix.cpp:894: error: invalid conversion from 'int*' to 'socklen_t*' network/qsocketdevice_unix.cpp:894: error: initializing argument 3 of 'int getsockname(int, sockaddr*, socklen_t*)' network/qsocketdevice_unix.cpp:898: error: invalid conversion from 'int*' to 'socklen_t*' network/qsocketdevice_unix.cpp:898: error: initializing argument 3 of 'int getpeername(int, sockaddr*, socklen_t*)' make[1]: * [.obj/release-shared-mt/qsocketdevice_unix.o] Error 1 make: * [sub-src] Error 2

Change History (3)

comment:1 Changed 16 years ago by dhjr@…

gcc --version powerpc-apple-darwin8-gcc-4.0.0 (GCC) 4.0.0 20041026 (Apple Computer, Inc. build 4061)

comment:2 Changed 16 years ago by jmpp@…

Owner: changed from darwinports-bugs@… to rshaw@…

comment:3 Changed 16 years ago by z3022016@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 3063 *

Note: See TracTickets for help on using tickets.