Opened 11 years ago

Closed 11 years ago

#31698 closed defect (duplicate)

erlang @R14B04 build hangs in Lion, in beam.smp, no cpu usage

Reported by: gthb (Gunnlaugur Thor Briem) Owned by: bfulgham@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: lion Cc: vkuznet (Valentin Kuznetsov), ys@…
Port: erlang

Description

The erlang build seems to be hung indefinitely, in a fresh macports on a new machine running Lion / XCode 4.2.

Attached are the main.log (appears truncated, probably output buffer not flushed) and pstree output showing the process being run (beam.smp).

Not sure how to help trace this further (am not Erlang-savvy), please advise.

Attachments (5)

erlang.main.log (36.0 KB) - added by gthb (Gunnlaugur Thor Briem) 11 years ago.
main.log from the hung install (appears truncated)
erlang.pstree.txt (5.8 KB) - added by gthb (Gunnlaugur Thor Briem) 11 years ago.
pstree output snippet showing the port invocation down to the hung process
erlang.beamkilled.main.log (38.8 KB) - added by gthb (Gunnlaugur Thor Briem) 11 years ago.
main.log (262.1 KB) - added by gthb (Gunnlaugur Thor Briem) 11 years ago.
logfile of failed build when patched with r81296
erlang.Portfile.patch (641 bytes) - added by ys@… 11 years ago.
added gcc45

Download all attachments as: .zip

Change History (19)

Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: erlang.main.log added

main.log from the hung install (appears truncated)

Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: erlang.pstree.txt added

pstree output snippet showing the port invocation down to the hung process

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Keywords: lion added; hang removed
Owner: changed from macports-tickets@… to dports@…

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: bfulgham@… removed
Owner: changed from dports@… to bfulgham@…

Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: erlang.beamkilled.main.log added

comment:3 Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Is there any further information that I can provide to help troubleshoot this?

comment:4 Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Hm: this sounds like a duplicate of #30012. That's supposed to be fixed 3 months ago with r81296, but the {{-O0}} flags in that were reverted in r84975, without explanation (accident?). So I guess this regressed?

I tried patching the portfile with r81296, and did get past the hang, but the build failed with another error:

Undefined symbols for architecture x86_64:
  "_bp_sched2ix", referenced from:
      _load_nif_2 in erl_nif.o
      _is_break in beam_bp.o
ld: symbol(s) not found for architecture x86_64

I'll attach the full log from that failed build of the patched port.

Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: main.log added

logfile of failed build when patched with r81296

comment:5 Changed 11 years ago by vkuznet (Valentin Kuznetsov)

Cc: vkuznet@… added

Cc Me!

comment:6 Changed 11 years ago by vkuznet (Valentin Kuznetsov)

See uploaded erlang.portfile.patch in #31585. With this patch I was able to build erlang and it works on Lion.

comment:7 Changed 11 years ago by vkuznet (Valentin Kuznetsov)

BTW, I build it with the following command

sudo port install erlang +ssl

comment:8 Changed 11 years ago by gthb (Gunnlaugur Thor Briem)

Yep, that worked for me too. Thanks!

comment:9 in reply to:  4 Changed 11 years ago by bfulgham@…

Replying to gunnlaugur@…:

Hm: this sounds like a duplicate of #30012. That's supposed to be fixed 3 months ago with r81296, but the {{-O0}} flags in that were reverted in r84975, without explanation (accident?). So I guess this regressed?

No. The upstream sources changed such that Clang properly builds Erlang. I'm not sure why you are experiencing the problems you are.

comment:10 Changed 11 years ago by conradwt (Conrad Taylor)

It appears to be hanging for me at the following line:

erlc -W  +debug_info +inline -o../ebin hipe_rtl.erl
(no error logger present) error: "Error in process <0.1.0> with exit value: {{badfun,[<<5 bytes>>,<<142 bytes>>,<<9 bytes>>,<<3 bytes>>,<<2 bytes>>,<<5 bytes>>,<<15 bytes>>,<<2 bytes>>,<<8 bytes>>,<<8 bytes>>,<<5 bytes>>,<<7 bytes>>,<<5 bytes>>,<<11 bytes>>,<<2 bytes>>,<<11 bytes>>,<<15 bytes>>,<<4 bytes>>,<<145 bytes>>,<<5 bytes>>,<<1 byte>>,<<7 bytes>>,<<10 bytes>>,<<7 bytes>>,<<6 bytes>>,<<7 bytes>>,<<7 bytes>>,<<6 bytes>>,<<12 bytes>>]},[{erlang,apply,2}]}\n"

comment:11 in reply to:  10 Changed 11 years ago by cheezy@…

I'm getting the same error at the same place.

Changed 11 years ago by ys@…

Attachment: erlang.Portfile.patch added

added gcc45

comment:12 Changed 11 years ago by ys@…

Cc: ys@… added

Cc Me!

comment:13 Changed 11 years ago by ys@…

couldn't get it working with the patch file from #31585, added gcc45 for lion, that worked for me, see erlang.Portfile.patch

comment:14 Changed 11 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.