Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#31831 closed defect (worksforme)

virtuoso: Waiting virtuoso start on port 1111...

Reported by: hobbsilla@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: mkae (Marko Käning), macports@…
Port: virtuoso

Description

I have a Macbook Pro 5,5 (Mid 2009) running Lion 10.7.2 with Xcode 4.2 installed and MacPorts update to 2.0.3. I'm trying to build kdenlive and need the virtuoso dependency to be successfully built in order to continue with installation. I've tried reinstalling it [virtuoso] about three times and on the third attempt I installed in verbose mode which allowed me to see where the problem occurs. It seems like the installation was going smooth until I got a Briefcase Application creation step and the Virtuoso server wasn't starting Port 1111. Attached is the log file.

Attachments (1)

main.log (1.3 MB) - added by hobbsilla@… 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by hobbsilla@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: virtuoso removed
Owner: changed from macports-tickets@… to snc@…
Port: virtuoso added
Summary: Virtuoso fails to finish building because of port 1111 issuevirtuoso: Waiting virtuoso start on port 1111...

comment:2 Changed 9 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:3 Changed 9 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

comment:ticket:31908:10 says this problem can be worked around by temporarily disabling your firewall.

comment:5 Changed 9 years ago by mkae (Marko Käning)

It seems that this ticket has been resolved with the update to version 6.1.4.

Can the original poster confirm this???

comment:6 Changed 9 years ago by hobbsilla@…

It appears the issue was resolved. I however am not using version 6.1.4. You can close the ticket.

comment:7 Changed 9 years ago by mkae (Marko Käning)

Resolution: worksforme
Status: newclosed

comment:8 Changed 9 years ago by macports@…

Resolution: worksforme
Status: closedreopened

not resolved for me. I still get:

...
=====================================================================
=  STARTED RDF Mappers PACKAGING
=  Sat Nov 5 23:33:24 CET 2011
=====================================================================

Shutdown Virtuoso Server...
cp: sponger_front_page/skin is a directory (not copied).
VAD Sticker vad_dav.xml creation...
VAD Sticker vad_fs.xml creation...
Virtuoso.ini creation...
The VDBMS server process terminated prematurely
after initializing network connections.
Waiting Virtuoso Server start on port 1111...
Waiting Virtuoso Server start on port 1111...
...

I have no firewall running, so workaround mentioned in comment 4 does not work for me. I'm using macports 2.0.3 and trying to compile virtuoso 6.1.4 Any

comment:9 Changed 9 years ago by hobbsilla@…

I recommend you sudo port clean virtuoso. Restart your computer and possibly try building in a different wireless network. Your router might have a built in firewall. I know it sounds really anecdotal but I ran my installation in verbose mode in a different network and when it tried to start at port 1111, it didn't even wait a second. It made an immediate connection and finished building shortly afterwards.

comment:10 Changed 9 years ago by nerdling (Jeremy Lavergne)

Resolution: worksforme
Status: reopenedclosed

comment:11 Changed 9 years ago by macports@…

i was able to compile virtuoso successfully after reboot, thanks

Note: See TracTickets for help on using tickets.