Opened 8 years ago

Closed 8 years ago

#31860 closed defect (duplicate)

par2 build error.

Reported by: h_atac@… Owned by: julian@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: neverpanic (Clemens Lang)
Port: par2

Description (last modified by neverpanic (Clemens Lang))

It couldn't be compiled. It gives error in par2fileformat.h file.

:info:build ./par2fileformat.h./par2fileformat.h::8787::25./par2fileformat.h:: 25error: :flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'
:info:build  87:25:flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'error:  
:info:build   FILEVERIFICATIONENTRY entries[];
:info:build :                        ^error: 
:info:build  flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'error: 
:info:build   FILEVERIFICATIONENTRY entries[];
:info:build                         ^  FILEVERIFICATIONENTRY entries[];
:info:build 
:info:build flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'
:info:build flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'flexible array member 'entries' of non-POD element type 'FILEVERIFICATIONENTRY []'
:info:build 
:info:build                         ^
:info:build   FILEVERIFICATIONENTRY entries[];
:info:build                         ^  FILEVERIFICATIONENTRY entries[];
:info:build 
:info:build                         ^  FILEVERIFICATIONENTRY entries[];
:info:build 
:info:build                         ^

There are lots of other warnings but at least this error causes build to stop.

Attachments (1)

main.log (47.9 KB) - added by h_atac@… 8 years ago.
Build log

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by h_atac@…

Attachment: main.log added

Build log

comment:1 Changed 8 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Keywords: par2 removed
Owner: changed from macports-tickets@… to julian@…

Please remember to Cc the maintainer. What version of Xcode are you using? Seems like a clang-issue to me, which could be easily resolved by the usual

if {${configure.compiler} == "clang"}{
   configure.compiler llvm-gcc-4.2
}

comment:2 Changed 8 years ago by h_atac@…

I'm using Xcode 4.3 on 10.7 (I'm an iOS developer). Could this be a problem?

comment:3 Changed 8 years ago by software@…

This is a duplicate report of #31789

cal: your suggestion works for me. I uploaded a patch to #31789. Thanks.

comment:4 Changed 8 years ago by neverpanic (Clemens Lang)

Cc: cal@… added

Cc Me!

comment:5 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: duplicate
Status: newclosed

Duplicate of #31789, fixed in r87264.

Note: See TracTickets for help on using tickets.