Opened 10 years ago

Closed 10 years ago

#31868 closed defect (duplicate)

opencv @2.3.1a Configure failure: shell command failed

Reported by: andrew.c.stewart@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: opencv

Description (last modified by ryandesign (Ryan Schmidt))

Received the following error while trying to upgrade opencv to 2.3.1a ( #31818 ). Uninstalled and reinstalled opencv and received the same error.

kg-ast:build astewart$ sudo port install opencv
Password:
--->  Computing dependencies for opencv
--->  Configuring opencv
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Log for opencv is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_opencv/opencv/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (74.1 KB) - added by andrew.c.stewart@… 10 years ago.
opencv/main.log

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by andrew.c.stewart@…

Attachment: main.log added

opencv/main.log

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: opencv removed

The log shows this is not a clean build attempt. Please clean and try again.

sudo port clean opencv

Looks like this could be a duplicate of #29223.

comment:2 Changed 10 years ago by andrew.c.stewart@…

Yup, needed a clean (still new to MacPorts, sorry). Thanks for the help, it builds fine now.

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.