Opened 9 years ago

Closed 8 years ago

#31930 closed defect (fixed)

py27-pyside build fails with qt4-mac +framework

Reported by: public@… Owned by: mamoll (Mark Moll)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: michaelld (Michael Dickens)
Port: py27-pyside

Description

Although I already managed to build and install py27-pyside I am having problems with the latest update. I even tried uninstalling all Qt related dependencies but still no luck.

I have attached my build log

Attachments (2)

main.log (117.1 KB) - added by public@… 9 years ago.
Build log
main-gcc.log (62.6 KB) - added by public@… 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by public@…

Attachment: main.log added

Build log

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mmoll@…
Summary: pyside build failpy27-pyside build fail

The relevant error seems to be:

fatal error: 'QtDesigner/QtDesigner' file not found

Perhaps this is what we discovered before, that clang ignores CPATH and LIBRARY_PATH.

You could try to use llvm-gcc-4.2 instead.

Changed 9 years ago by public@…

Attachment: main-gcc.log added

comment:2 in reply to:  1 Changed 9 years ago by public@…

Replying to ryandesign@…:

The relevant error seems to be:

fatal error: 'QtDesigner/QtDesigner' file not found

Perhaps this is what we discovered before, that clang ignores CPATH and LIBRARY_PATH.

You could try to use llvm-gcc-4.2 instead.

OK, I got half solution, thanks!

Part of the problem was my Qt variant. First time I tried to compile with Sadly you could not see the variants of my dependencies in the log:

qt4-mac @4.7.4_1+debug+demos+examples+framework+quartz

I noticed that there is something not logged in main-gcc. I repeated myself the last offending command to see if I could get some extra info. I found out the last error was because it could not find /opt/local/lib/libQtCore.4.dylib. So I installed:

qt4-mac @4.7.4_1+quartz

In that case I works, but I need +framework for development. Or at least, I've heard it is better to have Qt as a framework for development (and it is the default installation mode of the official Qt binaries)

so far the problem is that:

  1. py27-side does not compile with the default compiler
  2. py27-side does not compile when Qt is installed as a framework
  3. ... macports error log do not log the variants of the failing package dependencies ???

comment:3 Changed 9 years ago by jmroot (Joshua Root)

Cc: michaelld@… added
Keywords: pyside qt python removed
Summary: py27-pyside build failpy27-pyside build fails with qt4-mac +framework

1.1.0 appears to have built successfully on Lion, so the clang issue seems to be resolved at least.

comment:4 Changed 8 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

pyside build and works fine for me using the qt4-mac @4.8.4_3. I'm closing this ticket as fixed.

Note: See TracTickets for help on using tickets.