Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#31972 closed defect (fixed)

Whois fails to build on Lion with clang

Reported by: bruns@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cooljeanius (Eric Gallager)
Port: whois

Description

Hello, the port 'whois' fails to build on Lion with Xcode 4.2 due to using clang, claiming can't find 'ip_del.h'.

Rebuild using:

sudo port install whois configure.compiler=llvm-gcc-4.2

appears to resolve the issue and allows me to install whois correctly.

Attachments (1)

main.log (15.5 KB) - added by bruns@… 9 years ago.
Error output

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: whois removed
Owner: changed from macports-tickets@… to ryandesign@…

Could you attach the complete main.log from the failed attempt with clang? I get a different error on Snow Leopard with Xcode 3.2.6, but that could be because my version of clang is older.

Changed 9 years ago by bruns@…

Attachment: main.log added

Error output

comment:2 Changed 9 years ago by bruns@…

I've actually gotten a different error this time while compiling today:

:info:configure clang: error: the clang compiler does not support '-MG'

I'll see if I can reproduce the previous error from when I opened the ticket.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Yes that is the error I was getting. That's apparently been fixed by the developers of clang, but I guess it's not a part of the version of clang in Xcode 4.2 yet.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Status: newassigned

If I simply try again, without cleaning, then I get the error about the missing ip_del.h; this is not surprising since ip_del.h is a file that the configure phase would have created, if it had worked correctly.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

Fixed in r87044 by using llvm-gcc-4.2 instead of clang. Thanks for the report.

comment:6 Changed 9 years ago by bruns@…

Ah, okay. I must have not noticed it failing to install/update previously. I just confirmed the same behavior.

For reference, clang on Lion with XCode 4.2 is:

Apple clang version 3.0 (tags/Apple/clang-211.10.1) (based on LLVM 3.0svn)
Target: x86_64-apple-darwin11.2.0
Thread model: posix

Thanks for fixing this!

comment:7 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.